Cannot get map services to work with Open Data...

4330
4
01-27-2015 07:22 AM
JohnReese1
New Contributor II

Within the Open Data FAQ:

Does Open Data work with Map Services?

Yes. Open Data can work with your ArcGIS for Server Map Services. If you register the whole service as an Item in ArcGIS Online, when shared to ArcGIS Open Data, each layer will appear as an individual dataset. If you would like to provide a detailed description and unique tags for each layer, you must register the layers individually as Items in ArcGIS Online.

Whenever I attempt to download as a shapefile, the Activity tray always returns "shapefile – An error occured while processing this dataset." Not sure what causes this error. We're using ArcGIS Server 10.2.2 to host the data.

When I change the service url to the feature service url, the download suddenly works and I get no error. I'm curious to see if anyone else has encountered the same issue. I can obviously republish all of our services with feature access enabled as a workaround, but I would like to know why the map services don't work when the FAQ clearly states that they can.

Any insight would be appreciated :)

0 Kudos
4 Replies
CourtneyClaessens
Occasional Contributor III

Hi John,

Map services should indeed be downloading properly. Will you please provide a link to your site and a link to the map service in question? We can look into what might be causing this.

Thanks!

JohnReese1
New Contributor II

Thanks for the quick response, Courtney.

The Open Data url is Home | Stark County Ohio Open Data

I have already changed the majority of the map services that have given me issues into feature services. One of the few map services left untouched is our Parcel Sales service. The url is Dataset | Stark County Ohio Open Data

This specific service may not be the best example because it is published off of a SQL view (different from the rest of our services). I haven't confirmed that this one works as a feature service, but every other service that I have made that change to has suddenly started working.

If the Parcel Sales service isn't a viable example, and you really want to figure out what the issue was for my standard map services, I can alter the service url from feature back to map, and assuming the issue is remains, you can explore the issue.

Please let me know if you need any additional info. Thanks again for looking into this.

0 Kudos
CourtneyClaessens
Occasional Contributor III

Parcel Sales seems to be working now as a map service -- are you still experiencing this issue on your end?

JohnReese1
New Contributor II

As of this morning, it is working on my end as well. You must have a magical connection to the internet, and for that, I thank you. Not sure what the initial cause was, but I'm gonna treat it like it was never an issue unless it pops up again. If that happens, I'll probably open an Esri Support Case and post any information I garner, on this thread.

0 Kudos