ArcGIS Hub supporting https on custom domains

2686
35
Jump to solution
06-08-2018 06:50 AM
DarrenHaag
New Contributor III

A Question on ArcGIS Hub / Open Data.  

Is there a timeframe for supporting https on custom domains?  If not, is there currently a workaround that can be applied (requesting a new ssl, etc..) to ensure https traffic has no issue accessing the custom domain?

Tags (4)
0 Kudos
35 Replies
GrahamHudgins
Esri Regular Contributor

We have issued HTTPS certificates for all the existing custom domains that we could. We ran into a few that had issues with how their domain issuing authority set up their domain that we're working through.

Later this year we'll be adding support for enforcement on your custom domains.

Please test out your domain over HTTPS and let me know if you have problems!

Edit: also all new custom domains registered to a Hub Site should get their HTTPS certificate within 24 hours

View solution in original post

JoelMeier
Occasional Contributor II

I am still getting a not secure error:

0 Kudos
GrahamHudgins
Esri Regular Contributor

it appears your CNAME was not setup to exactly to our documentation. You need to set your CNAME according to the below instructions exactly: Rather than setting the CNAME to your site's URL you set it to the hub.arcgis.com URL so our infrastructure can let your CNAME move from site to site. 

Given a few others have had the same issue we're going to make a few updates to the UI that sets this in the coming months. 

JoelMeier
Occasional Contributor II

Yep you are correct, we had to do that originally because it wasn't working the way you describe before. I swapped it over this morning through and the new CNAME is working without issue. Thank you

0 Kudos
JoelMeier
Occasional Contributor II

I can now go to https://maps.grey.ca and that works fine. However when I type in just maps.grey.ca into a url bar it defaults to the unsecured version. Are there are redirects on your end to ensure it's going to the https version?

0 Kudos
GrahamHudgins
Esri Regular Contributor

We're planning on enhancing the URL configuration (and validation) process for custom domains in the next few months. As part of that, we'll be allowing users to enable Enforce HTTPS for their custom domains once we have the validation that the cert process was successful. 

DarrenHaag
New Contributor III

The site worked when visiting through https.

Thank You and the team for their hard work on this!

Quick question, we will be doing a major push on our open data initiative and I am about halfway done building the site.  When we push this live, it will also have a custom domain.  Are any new sites automatically getting a cert or should we work with esri to make sure it happens?

0 Kudos
GrahamHudgins
Esri Regular Contributor

We should issue a cert within 24 hours of your domain being registered to your Hub Site.

0 Kudos
NathanEnge
Esri Contributor

Graham

Is the approx time still about 24 hrs to get a cert issued for custom domains?

https://office.esripacific.ca 

cheers

nathan

0 Kudos
GrahamHudgins
Esri Regular Contributor

that's our under promise over deliver guarantee! 

*is not an actual guarantee, there are a lot of external factors at play for certificate generation. :tm:

we usually turn them around much quicker than that

0 Kudos