Strange Behavior With the ActiveMQ Transport...

03-01-2019 06:51 AM
New Contributor

Hey, all -  Been working with GeoEvent for a little while now (since 10.5); because we use ActiveMQ a lot here, I downloaded, built and used the ActiveMQ-Transport a great deal.  Since upgrading to 10.6 though, things have been a little tricky.  I download the latest code and compile it with the latest GeoEvent SDK - it builds fine, but when I try to upload it from the GeoEvent Manager interface nothing happens.  Here's where it starts getting weird: I physically copy the new jar file to the server itself and drop it in the GeoEvent/Deploy directory and it shows up perfectly along with all the others. Put together a Connector to test it out and everything behaved -- set up all the properties (shown, advanced and hidden), saved it, and went to set up the Output. I saw in the list that it was still 'Status: starting' but went to set it up in the interim. The 'shown properties' were all there and I filled them in; hit the 'advanced' drop-down and there was nothing there.  For this test case, that didn't matter so I went to add it to a GeoService to see how it worked. Added it, did a direct connection to the Output; 'shown' and 'advanced' properties were all in the the popup -- the 'hidden' properties displayed underneath the 'Advanced' drop-down part. Went back to the Connector to see if I'd screwed that up somehow.  The main part of the Connector was fine but the Properties boxes were all wrong: two of my 'shown' properties were missing and - even *more* troubling - ALL of the 'advanced' and 'hidden' ones were gone. Empty Boxes. Am I doing something wrong here?  This process worked perfectly in 10.5.  Please advise; I'm by no means proud of the workaround I'm using in the interim...

0 Kudos
0 Replies