GEP through a Proxy

3787
7
07-20-2014 09:20 PM
DarrylWilson
New Contributor II

Hi there,

Has anyone had any experience using the GEP through a firewall?

I'm having difficulty using a Proxy URL for an https-in type input.

Best Regards

Darryl

Tags (1)
Reply
0 Kudos
7 Replies
MorakotPilouk
Occasional Contributor II

For GEP 10.2.2, proxy can be configured by editing the file <GEP_Installation>\etc\com.ges.httpclient.cfg, e.g.

#Set value to <host>:<port>

httpclient.proxy.hostAndPort=myproxy.com:8080

You will need to stop and restart GeoEvent Processor service in Windows Service Manager for the setting to become effective. Please note this proxy is for the HTTP-based transport for the entire  GEP.

Reply
0 Kudos
DarrylWilson
New Contributor II

Hi there,

Thanks, we decided to build our own proxy and point the GEP input to that.

However, looking in the above directory I can find "com.ges.httpclient.cfg". I was hoping to increase the time-out value for http request and imagine this would be the place to do so - is this a correct assumption?

With the "com.ges.httpclient.cfg" file is this an add-in or have we done something wrong with the install?

Best Regards

Darryl

Reply
0 Kudos
DarrylWilson
New Contributor II

Edit to above, should read:

However, looking in the above directory I can't find "com.ges.httpclient.cfg".

Reply
0 Kudos
JavierDelgadillo
Esri Contributor

Darryl,

Are you using GeoEvent 10.2.2?  In prior versions, that config file was not there.

Unfortunately, timeouts aren't modifiable in this config file.  All of our Http Connections have a timeout of 30 seconds as we try to stay as close to real-time as possible.

-Javier

Reply
0 Kudos
DarrylWilson
New Contributor II

Hi there,

We are using 10.2.1. What is the default http input time out for this version? From testing it appears to be only around 2-3 seconds.

Best Regards

Darryl

Reply
0 Kudos
JavierDelgadillo
Esri Contributor

Darryl,

Please go through tech-support to create an issue so that we can get to the bottom of this.

-Javier

Reply
0 Kudos
KDeVogelaere
Occasional Contributor

Darryl, Try setting these Proxy configurations (screenshots attached): GeoEvent Processor - Feed Parsing error: can't find the next feed