GeoEvent Server: Kafka Error ConsumerCoordinator

699
1
10-22-2020 11:33 PM
Stefan_Jung
Esri Contributor

Hey,

in a 10.8.1 environment we currently have a strange behavior. Very often the GeoEvent Server is not responding anymore and the REST interface will be unavailable etc. 

In the kafka log we still get the following error message all few seconds:

ERROR | pool-16-thread-1 | ConsumerCoordinator   | 60 - com.esri.ges.framework.messaging.jms-messaging - 10.8.1 | [Consumer clientId=consumer-2, groupId=****] Offset commit failed on partition *** at offset xxxx: The coordinator is not aware of this member.

What is the best solution to solve this problem? For the moment we tested stuff like restart, clear data folder, redeploy custom components etc.

Best,

Stefan

0 Kudos
1 Reply
Jordan
by
New Contributor II

Hi @Stefan_Jung,

We have also recently seen this happen with out GeoEvent Server at 10.8.1.

It throws that same error in the logs for pretty much every output we have registered within GeoEvent. Ours was left overnight and a few hours later appears to show that the outputs are back working again. However, all of the geoevent services are stopped when we next login and we have to manually start them again.

Any advice on what this may be tied to within the greater Enterprise stack?

Cheers,

Jordan 

0 Kudos