Error using Web Service from transport

3880
1
12-12-2014 12:18 PM
New Contributor III

I am developing a transport for GeoEvent 10.2.2 that invokes a Web Service. The Web Service client needs the following jar files:

  • axis.jar
  • jaxrpc.jar
  • javax.wsdl_1.6.2.v201012040545.jar
  • commons-discovery-0.2.jar
  • saaj.jar

When I copy these jar files in the directory "C:\Program Files\ArcGIS\Server\GeoEventProcessor\deploy​" and then I start GeoEvent Processor, the following erros happen:

  • wrapper.log (I attach the file)
  • karaf.log (I attach the file)

Does anybody know where i have to copy these jar files so that the transport can use de Web Service Client and the errors, that I have mentioned, do not happen when GeoEvent starts?

Regards,

Luis

Reply
0 Kudos
1 Reply
Occasional Contributor II

Hi Luis,

GeoEvent expects any jars in /deploy to be in a certain format.  And any jars in /deploy are expected to be for a transport, adapter, or processor.  The jars you are talking about are dependencies for your transport, but GeoEvent doesn't know this and is trying to process them as if they were transports, adapters, or processors.

Are you using Maven to build your transport?  When making custom GeoEvent components, you really want to start by using one of the existing samples.  You can make a copy of one you think is closest to what you want, swap out the guts of the code, then build using the Maven configuration that was already set up in the SDK samples. 

Check out page 18 of the GeoEvent Developer Guide, at section "Starting a New Project".

Mark

Reply
0 Kudos