ArcGIS GeoEvent 10.6: Server is not licensed error

547
4
06-22-2018 01:48 PM
Highlighted
Esri Contributor

Hi,

I'm getting this error message whenever I try to access the GeoEvent 10.6 manager site:

Even though, ArcGIS Server seems to be correctly licensed:

I've re-loaded the ECP file, edited de Keycodes file, restarted services and even the server itself without any Success.

My OS is Ubuntu Server 16.04

Thanks ins advance for your help.

4 Replies
Highlighted
Esri Contributor

the karaf.log says:

Even though, the keycodes file is present at:

Reply
0 Kudos
Highlighted
Occasional Contributor

Did you ever find a solution Sergio Eduardo Galindo ? I have the same issue in 10.5.1

Reply
0 Kudos
Highlighted
Occasional Contributor III

Langdon,

I recently had this issue myself on a Red Hat VM which was abruptly turned off. In my case, I think some level of corruption occurred and I had to blow everything away and re-deploy on a new VM. Assuming your situation is like Sergio's and everything checks out with your licensing/keycodes file and there is no other obvious answer, I would start with checking folder permissions. You'll want to ensure that the account running GeoEvent/ArcGIS Server has appropriate permissions on content/application directories. Assuming you're on Linux, that means recursive 770 permissions. It's also a good idea to have that account be the owner of directories.

If all that looks good and still you get that error, then you can try the below (ideally you have a backup of your configuration):

  1. Stop the geoevent.service and geoeventGateway.service
  2. Uninstall GeoEvent Server
  3. Rename/delete the following folders:
    • /home/esri/.esri/GeoEvent
    • /home/esri/.esri/GeoEvent-Gateway
    • /home/esri/arcgis/server/GeoEvent
  4. Re-install GeoEvent and re-authorize
Highlighted
Occasional Contributor

Thanks Earl! We were able to resolve by going through the authorization wizard again. 

Reply
0 Kudos