Cannot create mobile map cache files

3328
9
11-09-2010 11:43 AM
JosephThirolf
New Contributor
90 days ago, I was able to use the ArcGIS 10 Toolboxes/Mobile Tools/Create Mobile Map geoprocessing tool to create and populate a MobileCache folder. Now that I am back working on on that project again, I get an "ERROR 001143: Background server threw an exception" error. The log history XML file does not have any futher information. Has anyone encountered this or have any clues as to what could be causing this error? Uninstalling and reinstaling the mobile component results in the same error. I even tried using the tool to create and populate my 90 day old job to no avail.

The ArcGIS 10 Desktop Help documentation does not list this error code in their "Tool errors and warnings:" documentation.

Best Regards,
Joe
0 Kudos
9 Replies
AkhilParujanwala
New Contributor III
My only guess is that you did not set your extent.

Double click on the dataframe "Layers", click on the Data Frame Tab, click on Other then click on Specify Extent then click OK then OK again.

Then run the GP tool and see if that works.
0 Kudos
DeniseKing
Esri Regular Contributor
Hi Joe,

One suggestion is to disable background geoprocessing by clicking Geoprocessing > Geoprocessing Options on the Standard toolbar in ArcMap and then re-run the tool. Some geoprocessing tools need as much of your computer resources available and when a tool fails because there is not enough memory available you can try the following:


  1. Identify and exit  nonessential memory-intensive applications.

  2. Disable background  processing from the Geoprocessing Options dialog box  (Geoprocessing >  Geoprocessing Options). This will shut down the background process and  free up resources.

  3. Rerun the  tool.

Using this procedure, background processing is bypassed; the additional background process  does not start, and the resources it would consume is now available for your  tool to make use of. While the tool is executing, avoid starting any  memory-intensive applications.

If the above doesn't help to resolve the "ERROR 001143: Background server threw an exception" error, please contact Esri Support and log this issue so we can help in troubleshooting this error.

Thanks,
Denise
0 Kudos
JosephThirolf
New Contributor
Thanks to both of you for responding. I have the problem fixed now. This is a development machine used by multiple people to play around with ArcGIS 10, so something got corrupted in the last 90 days.

The fix...I removed all ESRI software, clean up ESRI and ArcGIS references (at least most of them) in the registery, then reloaded everything. That is all I did and now it works like it should. I hate not to find the real source of the problem, but I need to get on with our development.

Best Regards,
Joe
0 Kudos
BerendVeldkamp
Occasional Contributor II
I got the same problem, but could fix it by running the 'repair' option of the ArcGIS Mobile installer. Still not ideal, but at least it takes less time than a complete uninstall/install cycle.
0 Kudos
BradChappell
New Contributor
Disabling background process worked for me.

I certainly hope this gets fixed though, don't like this solution.
0 Kudos
MichalisAvraam
New Contributor III
Denise,

I had a similar error, but not using mobile processes. I am simply trying to convert polygons to raster. I have polygons generated through buffers at 3 distances. For the 5km distance, the operation worked fine. But when it comes to 10 and 15km, the operation fails with an ERROR 001134. I tried fixing the problem based on your suggestions, but to no avail. I tried to see if it was a resources error as well, but I am well below the resources I have available (this is a quad core machine with 16GB of RAM).

Are there any other suggestions? I will try the Repair Installation procedure next.



Hi Joe,

One suggestion is to disable background geoprocessing by clicking Geoprocessing > Geoprocessing Options on the Standard toolbar in ArcMap and then re-run the tool. Some geoprocessing tools need as much of your computer resources available and when a tool fails because there is not enough memory available you can try the following:


  1. Identify and exit  nonessential memory-intensive applications.

  2. Disable background  processing from the Geoprocessing Options dialog box  (Geoprocessing >  Geoprocessing Options). This will shut down the background process and  free up resources.

  3. Rerun the  tool.

Using this procedure, background processing is bypassed; the additional background process  does not start, and the resources it would consume is now available for your  tool to make use of. While the tool is executing, avoid starting any  memory-intensive applications.

If the above doesn't help to resolve the "ERROR 001143: Background server threw an exception" error, please contact Esri Support and log this issue so we can help in troubleshooting this error.

Thanks,
Denise
0 Kudos
DeniseKing
Esri Regular Contributor
Michalis,

You do not mention the specific tool you are using but I assume you are using ArcToolbox > Conversion Tools > To Raster > Polygon to Raster for this process, is this correct? Do you receive the 'error 001143' with this tool? It is possible you are running into an issue with background processing. Please try running the tool with background processing disabled:

   1. In ArcMap > Geoprocessing menu
2. Geoprocessing Options
3. Background Processing group > uncheck Enable

I did not know whether you are using ArcGIS Desktop 10 SP3 but I am aware of a fix in Service Pack 3 that might resolve this issue.  Please install Service Pack 3 to see if this fixes the issue.  http://resources.arcgis.com/content/patches-and-service-packs?fa=viewPatch&PID=17&MetaID=1807

For faster response by other ArcGIS Desktop users, please post your questions on a more applicable product forum such as ArcGIS Desktop Forums - http://forums.arcgis.com/forums/5-ArcGIS-Desktop-General.

Cheers,
Denise
0 Kudos
MichalisAvraam
New Contributor III
Denise,

Thank you for your reply. You are correct on the tool (Conversion tools) and that I have background processing disabled. I am on 10 SP3 as well.

So... I am not sure what the problem is, or why it happens.

For now, I resolved in generating raster from polygons for every about 100 polygons, and then bringing them together (which is probably not the ideal situation, but it works).

Michalis


Michalis,

You do not mention the specific tool you are using but I assume you are using ArcToolbox > Conversion Tools > To Raster > Polygon to Raster for this process, is this correct? Do you receive the 'error 001143' with this tool? It is possible you are running into an issue with background processing. Please try running the tool with background processing disabled:

   1. In ArcMap > Geoprocessing menu
2. Geoprocessing Options
3. Background Processing group > uncheck Enable

I did not know whether you are using ArcGIS Desktop 10 SP3 but I am aware of a fix in Service Pack 3 that might resolve this issue.  Please install Service Pack 3 to see if this fixes the issue.  http://resources.arcgis.com/content/patches-and-service-packs?fa=viewPatch&PID=17&MetaID=1807

For faster response by other ArcGIS Desktop users, please post your questions on a more applicable product forum such as ArcGIS Desktop Forums - http://forums.arcgis.com/forums/5-ArcGIS-Desktop-General.

Cheers,
Denise
0 Kudos
JeffMcReynolds
New Contributor II
I experienced this same error (ERROR 001143: Background server threw an exception) when trying to run a TABLE to TABLE import from an XLS file to a File Geodatabase table.

The recommendation by Denise (ArcMap > Geoprocessing > Geoprocessing Options > uncheck the "Enable" box under Background Processing) solved my issue too.

I'm currently at v10.0 SP5.
0 Kudos