Help: ESRI Maps for MicroStrategy: Invalid redirect_uri

6087
10
09-02-2014 05:19 AM
TrinanjanBhanja
New Contributor

Hi All,

 

I have using the 30 day trial of ESRI Maps for MicroStrategy.

 

I have deployed the plugin to \MicroStrategy\Web ASPx\plugins\em4mstr.

 

I have updated the settings file at \MicroStrategy\Web ASPx\plugins\em4mstr\JavaScript\configuration as advised in the installation guide.


My Settings File:

define({

keepAliveInterval: 60000,

arcgisUrl:"http://tcsnsolbipm.maps.arcgis.com/",

arcgisSharing: true,

arcgisAuthType: "user", //or "app"

arcgisAppUser: "",

arcgisAppPassword: "",

arcgisAppId:"<App ID pasted here>",

selectionColor: "#FF0000",

incFetchSize:1000,

currencySymbol:"USD"

});


My MicroStrategy Web URL http://01hw498423.india.tcs.com/MicroStrategy/asp/ is on the intranet.


Whenever, I try to see the widget properties for a 'ESRI Maps for MicroStrategy widget' on a MicroStrategy dashboard, I get a popup with a 'Invalid redirect_uri Error: 400' error.


I also get an Oauth HTTP 400 window on some occassions. MicroStrategy Web is running on IIS & ASP.NET on a Windows Server 2008 R2 Enterprise box.


Please help.

0 Kudos
10 Replies
ChakaClarke
Esri Contributor

Ensure that you have added "http://01hw498423.india.tcs.com" and any other URL eg http://01hw498423 as the URI when registering you APP for which you have provided in the settings file arcgisAppId:"<App ID pasted here>" this, message the URL used to access services have not been registered as valid URI for the App.

For more information on registering an APP ID refer to the help documentation: http://location-analyticsdev.arcgis.com/en/maps-for-microstrategy/install-and-configure/generate-an-...

Cheers

Chaka

0 Kudos
ChakaClarke
Esri Contributor

App ID details should be...

If this is correct and you are still getting this error message let me know.

AppID.PNG

0 Kudos
RohitKhandelwal
New Contributor

Hi Chaka Clarke,

I am facing the same issue even when i have followed all the steps mentioned by you in this post.
Please refer the snapshot for reference.

1-9-2016 5-28-57 PM.png1-9-2016 5-30-09 PM.png

It would be really great if you would help me out with this error.

0 Kudos
AtsuhitoNAKANO
Esri Contributor

Hi Rohit Khandelwal,

In your case, which url did you use to access your MicroStrategy report including Esri Maps?

If accessing with http://localhost/MicroStrategy/asp/Main.aspx, you need to add http://localhost in to the Redirect URI's in App Registering.

On the other hand, if access with http://NICESS-LP09/MicroStrategy/asp/Main.aspx, you might be able to get the correct popup window.

At App Registration for Oauth, you need to add the URIs (hostname) you use when accessing to MSTR Report including Esri Maps.

2016-01-10_1625.png

RohitKhandelwal
New Contributor

Hi atsuhito_nakanoesrij-esridist,

Even when I have included the URI's as mentioned by you, still I get the spinning wheel wherein I am able to log in but I am not getting any of my Basemap loaded in MicroStrategy, elsewhere it shows just a spinning wheel. Do you have any idea about this behavior?

0 Kudos
AtsuhitoNAKANO
Esri Contributor

HI Rohit Khandelwal,

At first, could you get the login pop up shown correctly?

Then about the issue you encounter now, is it correct that the loading Esri Maps is not end after login your ArcGIS?

0 Kudos
RohitKhandelwal
New Contributor

Hi Atsuhito NAKANO,

Thanks for the update. As in the Pop-up, I need to approve the login credentials registered with ESRI and once I approve it, I only get the spinning wheel and no basemap from the cloud.Popup.PNG

0 Kudos
ChakaClarke
Esri Contributor

Hi Rohit, were you able to resolve the issue?

0 Kudos
RohitKhandelwal
New Contributor

Hi Chaka Clarke,

Nope. Still facing the same issue.

0 Kudos