Unable to perform bidirectional sync of the geodatabase

523
3
03-08-2021 11:05 AM
vijaybadugu
Occasional Contributor

I am getting error ": Unable to perform bidirectional sync of the geodatabase. The sync direction has been changed to downloadsync. None of the feature layers or tables referencing the geodatabase have the capabilities of create, update or delete required for bidirectional sync.  path: /private/var/mobile/Containers/Data/Application/979D7CE0-7D48-4DC9-8FDF-"

While Update check or sync, I am using ArcGIs Enterprise 10.8 and ArcGIS Field Maps.

 

Tags (1)
3 Replies
ClaireInbody1
Occasional Contributor

Did you ever get this solved? We are running into this error in Collector with Enterprise 10.8.1. Our offline data will sync but sometimes it will not and its starting to fail more and not properly sync our data. 

0 Kudos
JonathanDandois
New Contributor III

I was having this issue today with Enterprise 10.8.1 and Field Maps on iOS and got here through google.  Wracking my brains with trying to sort this out since other services from feature classes on the same DB worked just fine.  I am not 100% of this, but I ended up un-registering and re-registering the feature dataset as versioned without moving edits to base. Im trying to recreate the problem now with a different feature class from another feature dataset with traditional versioning and moving edits to base, and I am getting some errors popping up. But again, not sure if that's the solution for you.

0 Kudos
David_Brooks
MVP Regular Contributor

@JonathanDandois and @vijaybadugu, in the past, with Collector and Enterprise 10.6.1, I never used versioned EGDBs for Collector. We only worked with Feature Classes with Archiving enabled. 


David
..Maps with no limits..
0 Kudos