Unable to create offline version, and edits going straight to DEFAULT version

330
1
03-21-2022 09:39 PM
MichaelBell
New Contributor III

I'm currently working on getting a GIS up and running. Our data is hosted in Azure, and accessed via ArcServer. On the desktop, it's all working fine.

However, when going to Field Maps (or Collector), I try to make an edit, and my edits go straight into the DEFAULT version and into the database (even though I've protected the DEFAULT version and set my Feature Service to create a new version for each user). I've also tried this using a login that is not me (so someone who does not own the database).

Furthermore, when trying to create an offline version, I get the following (paraphrased) error (basically, code 400 unknown error):

 

Error downloading map: Error Domain=com.esri.arcgis.runtime.services.error Code=400 "Unknown error occurred" UserInfo={NSLocalizedFeatureReason=Failed to create replica., NSURL=<link to Feature Service replica job>, responseJSON={

error = {

code = 400;

description = "Failed to create replica.";

};

lastUpdatedTime = <timestamp>;

replicaName="";

resultUrl="";

status = Failed;

submissionTime = <timestamp>;

}, NSLocalizedDescription=Unknown error occurred}

 

As an aside, as mentioned I've tried in Collector with the same issue. I haven't tried in the REST endpoint, as I don't know how.

0 Kudos
1 Reply
AdhimoolamDeshknamoorthi
New Contributor

Me too get same issue in ArcGIS Filed Map  in ArcGIS Enterprises 10.9.1

any solution please help 

0 Kudos