Taking Field Maps offline with analysis/view layers

930
5
02-21-2023 01:57 PM
NoahWasserman
New Contributor III

I'm working on a field inspection Field Maps app but am having a hard time figuring how I can enable offline use (rural project site) AND visualize the results of these inspections on a webmap or Dashboard.  I would like to show which sites need maintenance, or have inspections due in next 90days, or need follow-up to a previous inspection report.  I have a point feature (sites) with a related table (inspection data collected in a Field Maps form).  I've been using this example but I've run into the problem of not being able to enable offline for my Field Map while having this analysis/view layer. It doesn't seem to work even if I create an analysis/view layer from the original feature service in a different ArcGIS web map.  How can I visualize the results of my field inspections while still making the Field Map and site inspection layer available offline?

0 Kudos
5 Replies
MitchellGrafstein
Occasional Contributor

Without seeing your map or knowing what the status is of your layers, I can at least provide a couple examples of what could be stopping you from taking your maps offline:

You can only have a layer or table in your map referenced once.  As in, you cannot add a layer twice to the map, and then edit the symbology or anything along those lines.

If you are using views, the same holds true as above, each view layer or table can only be referenced in the map once.

You will also need to make sure that sync is enabled for any view or source layer/table that you have added to your maps.  

Are you getting failures?  Or is the option to take the map offline not available?  (The option to take the map offline will also need to be toggle to on in case it was off for some reason.  You can find this under settings for the web map, under offline, and the toggle is "Enable Offline Mode.")  If you do not see the Offline tab under settings, then there is most likely an issue with one of your layers or tables in the map - most likely, sync may not be enabled.

If everything above checks out, and you are getting errors when trying to take maps offline, the biggest issue we have run into is in Enterprise when you update a source layer's domains, it will break the view's codedValues domain formatting at least in 10.8.1 - haven't tested this in 10.9.1 since we upgraded.  (We just update the fields, programmatically or through the REST API, in the view to match the source layer.)

I hope this helps. 

Mitchell Grafstein, Horticultural Inspector 1, NYS Dept. of Agriculture and Markets
0 Kudos
NoahWasserman
New Contributor III

Thanks for your thoughts.  I'm running a one-to-many (Field Maps reports in a related table to a point feature service) but I keep getting 1) a 'failed' when I try to package the managed areas for offline when it includes an analysis/view layer, and 2) the view layer stops drawing in the map after I try to package it.  I've create the majority of fields in Field Maps and the whole thing works for Offline use without the analysis/view layer.  Sync is enabled for all layers (see attached images).

0 Kudos
MitchellGrafstein
Occasional Contributor

You're welcome, happy to help.

Have you tried creating an offline area in the Field Maps mobile application to see if that is able to function?  You would then have access to the logs from Field Maps to see if it brings up any extra information.  (Settings --> Troubleshooting --> View Logs | Logging will also need to be toggled on.)

One issue I know with creating an offline package is that services that are shared with an update group (groups that allow services to be edited by group members among other things) will fail to generate (at least on our old Portal which was at 10.8.1.) Are you using ArcGIS Enterprise or ArcGIS Online?  

Even if we do not find the answer, at least we are drawing more attention to this topic.  This topic would also be relevant to ArcGIS Online or ArcGIS Enterprise depending on what you are using.

Mitchell Grafstein, Horticultural Inspector 1, NYS Dept. of Agriculture and Markets
NoahWasserman
New Contributor III

I'm working with ArcGIS Online.  Yes, I am sharing the map and layers with a group who have editing enabled.  In the Field Maps offline menu I'm able to take it offline, package an offline area, and sync without the analysis/view layer.  But the minute I add in an analysis layer it fails.  Right now I'm going to get Offline working and then return to this next week.  I will also go through the notes in this post . Will report back.

0 Kudos
MitchellGrafstein
Occasional Contributor

Best of luck, hope you figure it out. 

If you can grab the logs from the Field Maps mobile application, assuming it is showing the same behavior, that might provide some details.  The logs are rather verbose, so I recommend searching through them for "error" and "fail" to see if you get any quick hits.  Not sure if the AGOL activity logs might be of any use, but that is also a possibility to explore.   Exploring the Organization Activity Log CSV (esri.com)

I will keep an eye on this post as you get back to it.

Mitchell Grafstein, Horticultural Inspector 1, NYS Dept. of Agriculture and Markets
0 Kudos