Map Messed up for Unknown Reason

289
3
01-14-2021 11:42 AM
ChangNi1
New Contributor III

Hello,

We encountered a very confusing incident with Field Maps today. We don't know how it occurred so just going to go through it hoping someone can provide some suggestions.

My colleague prepared a map for our field crew yesterday. Layers are owned by different people in our organization (him and I). He was able to add sample data to the data collection layer. He also checked "allow to use in Field Maps" in map settings. Everything worked fine.

This morning I was notified that the field crew cannot see it in Field Maps. Turned out the "allow to use in Field Maps" became unchecked overnight (issue No.1).

After turning the option on I also moved the map to a different group. Shortly afterwards one technician told me that none of the layers would load for her while working fine for the other two people. (issue No.2).

I went through the layers and found one remained in the original group despite the map being shared to a new one (issue No.3). After fixing the sharing it showed up in Field Maps.

But nothing we tried worked for the two remaining layers. We also found editing was disabled for the data collection layer. There was no "Collect here" option in Field Maps, although editing was turned on in the layers settings (issue No.4).

In the end we had to make a new map. Same layers were used, and everything was functional again.

Please advice on what might have caused this, and what we can do to avoid future incidents.

Thanks!

0 Kudos
3 Replies
Linde_Carmack
New Contributor III

I'm not sure about your first three issues, but I think I can advise on #4. 

If you want to edit on a map in Field Maps, both the use in Field Maps and use in Collector boxes must be checked on the web map settings page. I've had this issue multiple times as it's not the most intuitive. If just the Field Maps box is checked, the map is visible in Field Maps but read only. Checking the use in Collector box is what permits editing (even if it will only ever be used in Field Maps). 

Carmack_Linde_1-1610657818164.png

Hope this helps on at least one of the issues!

 

0 Kudos
ChangNi1
New Contributor III

Thank you!

I tested it and this indeed seems to be the case. When I uncheck the Collector box the "collect" button disappears from Field Maps. Must keep that in mind :)

0 Kudos
ColinLawrence
Esri Regular Contributor

Hi @ChangNi1 ,

 

I cant comment on exactly what happened without reproducing it, but I can make a guess. First, Linde's comment on the check boxes is spot on. I commented on this thread with a little more clarification on that. For the scenario where things become "unchecked" mysteriously. Sometimes this can happen when making modifications in multiple tabs, i.e. you make a change to the check box in the item details and save in one tab, then in another tab you save the Web Map from the map viewer page (without reloading the map). This can overwrite changes to the Web Map made in another tab.

 

When sharing a map to a Group it should prompt to share the layers in the same way; perhaps there was a problem with this workflow the first time you tried it (popup didnt appear or you dismissed it on accident). Let me know if you have encounter consistent problems like this and I can try to help further.

 

Regards,

Colin

0 Kudos