Line streaming stops, feature lost

402
7
03-30-2021 10:36 AM
JayHodny
Occasional Contributor III

Hi. I am learning to use Field Maps.  I have created a simple line feature service, editable, and shared to my AGOL organization which contains one line template.  I am collecting walks I take each day.  I start Field Maps, start a new line feature, start streaming, then off I go.  The last two walks have been lengthy, 45 minutes to an hour in length.  When I returned after each, the features were not saved.  In the first case, I had trouble with the Stop Streaming command, eventually the app froze, and line feature lost.  In the second case, somewhere along the walk the path feature disappeared, as if it was never started.  I could see the path being drawn on my phone as I walked.  I redrew both paths in the service in Pro.

The Stop Streaming command has been problematic since I have started using Field Maps.  It seems very slow to respond when clicked.

Is there a time limit or length limit when creating line features in Field Maps?  And am I doing something wrong when attempting to stop streaming?

Thanks in advance, Jay

0 Kudos
7 Replies
ColinLawrence
Esri Contributor

Hi @JayHodny ,

 

Thank you for reporting this. Are you using Field Maps while connected or offline (ie have you downloaded the map to your device)? Could you also not the type of device and OS version it is running on? I am looking to see if I can reproduce this problem.

Also, what is the Streaming Interval you are using? This can be changed in the Collection settings within the app or while streaming from the overflow menu. If you set this to a less frequent interval do you have the same issues?

 

Regards,

Colin

0 Kudos
JayHodny
Occasional Contributor III

Hi Colin,

Thanks for the reply.  I may have found the cause, at least it is worth investigating.  I had replaced an Esri reference basemap with an aerial image.  It appeared that on shorter walks, I could get away with using the image and collect the path.  I went back into the configure Field Maps browser window, and saw the error about needing a map layer that is supported for offline mode.  I switched to an Esri reference basemap, and the error went away.  I will give this give this configuration a try.

I have an Android phone, Samsung S9, Android version 10 software, which I update whenever I get the message to update software, looks like Feb 1, 2021 was the last update.

The Streaming Interval was set to 10 feet, I had not messed with this setting yet.  I changed it to 20 feet, which still may be too often.

I will hit the pavement again and let you know!

Regards,

Jay

JayHodny_0-1617213897100.png

 

 

0 Kudos
ColinLawrence
Esri Contributor

@JayHodny I was able to reproduce this on my own devices. We have logged an internal issue to investigate further. I do not believe it is related to your basemap layers. Some things I have found that seem to alleviate the issue:

- Periodically bring the app to the foreground. The cause of the freeze is definitely extended streaming in the background or with the screen asleep. 

- Set a larger streaming interval (say 50ft +) or an equivalent time setting. 

Let me know if you have success trying these out.

 

Regards,

Colin

0 Kudos
JayHodny
Occasional Contributor III

Hi Colin,

Thanks for your reply and I am sorry for not getting back to you sooner.  As per your suggestions, I have been mindful of checking the app while I am out (bring the app to the foreground on my phone), and I set the streaming interval to 50 feet.  Either or both appear to have brought additional stability to the app performance.  It still takes a little time to Stop Streaming and have the app kick out of that mode.  I have been able to save extended line feature streaming now and I have not lost a line feature on several outings.  Thank you for your help.

Regards,

Jay

0 Kudos
ColinLawrence
Esri Contributor

Great to hear @JayHodny ; I am glad you have a workaround for the time being. We are investigating the cause of this issue further.

 

Regards,

Colin

0 Kudos
JeanFujikawa
New Contributor

Hi Colin, Has this issue been resolved in the software? 

0 Kudos
ColinLawrence
Esri Contributor

@JeanFujikawa Thank you for checking. Yes, we have put in a fix in the latest release Field Maps 21.2. Please let us know if you are still having issues with streaming over distances. 

 

Regards,

Colin

0 Kudos