Layer Name Duplication

225
5
Jump to solution
08-20-2021 09:32 AM
PaulGardiner
New Contributor III

Hoping this will be a simple solution...

I've Feature Layers to a Field Map survey. When the layers are added one is being named as expected but the other has the layer name repeated. Both were set up in exactly the same manner.

I've attached a clip of the issue. Any insights would be most welcome.

 

Thanks.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
PaulGardiner
New Contributor III

Just to update on this...

Looks like it was a bug of some sort as I removed the layer and added it back to the Map (all through Field Maps) and the name repetition issue had resolved.

View solution in original post

0 Kudos
5 Replies
AaronPulver
Esri Regular Contributor

How are you adding the layers to the map? Are you doing it in Map Viewer, Map Viewer Classic, within the Field Maps web app, or from the item details page (Add to new map)?

It's not really duplicating the name. If a Feature layer containing multiple layers is added to a map, the format is "<Feature Service Item Name> - <Layer Name>". So I'm guessing your item name is "Division 05 Survey Lines" and you have a layer that is also named "Division 05 Survey Lines" within in.

PaulGardiner
New Contributor III

The layer is being added through Field Maps. It's just mystifying me as I have 5 other surveys with similar point and line layers and this is the only one which I'm having this issue with. 

0 Kudos
AaronPulver
Esri Regular Contributor

Did you add the other layers via Field Maps as well?

PaulGardiner
New Contributor III

Yup, all layers were added through Field Maps. 

0 Kudos
PaulGardiner
New Contributor III

Just to update on this...

Looks like it was a bug of some sort as I removed the layer and added it back to the Map (all through Field Maps) and the name repetition issue had resolved.

View solution in original post

0 Kudos