Field maps submission error

982
5
05-13-2021 02:59 AM
LouiseHarris1
New Contributor III

HI

I have a created a form in Field Maps but when filling it out in the mobile app I can't submit it and I get the following message

'Unable to submit, Geodatabase value is null'

Any ideas why I am getting this message please?

0 Kudos
5 Replies
ColinLawrence
Esri Regular Contributor

Hi @LouiseHarris1 ,

 

Are you working with an offline map? Do you get the same error when consuming the live map (not downloaded)?

 

Regards,

Colin

0 Kudos
MollyWatson1
Occasional Contributor

I also get that error - 'Geodatabase Value is Null' in field maps. However, it occurs when I have opened field maps from a Workforce project.  When I try to change my assignment status in field maps, I get the error. Also, none of the attributes from the assignment feature service show up in the pop-up in Field Maps. However, they are in the attribute table if you view the feature service in a map viewer. This error did not occur when integrating Workforce with Collector. 

0 Kudos
GlenShepherd
Esri Contributor

Hi @LouiseHarris1 and @MollyWatson1 ,

Are you using Android mobile devices? Could you specify the version of the mobile app and the OS version of your device that is in-use when we receive this error message?

Are you copying or submitting a new feature when this occurs? Or is it just went submitting edits to existing features?

0 Kudos
MollyWatson1
Occasional Contributor

Hi Glen,

The error happens when using both Android and IPhone devices and the latest version of the mobile apps. It happened when we would try to edit existing features.  I worked with an ESRI analyst, and we figured out a solution.  We manually changed the URL template value in the Assignments Integration related table in ArcGIS online, instead of setting up the app. integration between Workforce and Field Maps in the Workforce project.  Here is an example of what the syntax looks like:

https://fieldmaps.arcgis.app/?referenceContext=updateFeature&itemID=d6da86a516fd4692bb149c22359f70f7...

We no longer get the error now. This process is not very well documented. I would not have figured it out on my own. 

Boris
by
New Contributor

I'm having a similar issue when trying to submit a point when finishing the form on mobile (android). I instead get and indefinite spinning wheel where it says "in progress". A coworker tried testing out, but they get an actual failed error where it says "1 or more attributes failed" even when all required form elements were filled in. Using version 22.1.2. Tried on android and iphone. Samsung tablet gives us "Unable to submit. Service error code 1000". 

0 Kudos