Select to view content in your preferred language

Feature Layer Views with floor aware layers not functioning in Field Maps app

664
4
Jump to solution
10-18-2023 09:12 AM
JDenham
New Contributor III

I'm looking for a solution that will allow us to efficiently collect indoor feature data.  Our data is hosted in an Enterprise (11.1) gdb, with specific user permissions controlled with the use of Feature Layer Views, with the primary interaction being through WAB applications.  Feature editing works great in WAB, but the need for field collection is increasing as we plan additional implementations, and I'd love to be able to use the mobile application for this.

My problem is that I'm able to get the floor filter to show up if I publish a web map directly from Pro, and then pull that web map into the Field Maps application, but any web map created in the enterprise portal, configured appropriately with floor aware layers etc., fails to show the floor filter in Field Maps when loaded.  I've tested this with and without referencing a Feature Layer View of the data in the web map to determine if it's a limitation of using Feature Layer Views.  It seems to be that the only web maps that have functional floor filtering capabilities in the Field Maps app are the ones directly published by pro.  This is a problem because it doesn't allow us to utilize the controls offered through feature layer views.  As soon as layers are removed/added in the directly published web map, the floor filter ceases to appear in the Field Maps app.  I'm new to the Field Maps app, so I'm hoping that I'm missing something.  If not, I simply cannot use field maps.

ESRI support simply stated that I should publish to a web map from Pro to have this functionality.  As stated above, this means that we cannot use Feature Layer Views.  I cannot be the only person needing to utilize feature layer views, swap and customize web map layers and still be able to use the Field Maps app.  🤔

Any help would be appreciated.

-J

 

 

0 Kudos
1 Solution

Accepted Solutions
KathleenCSki
New Contributor III

This worked in 10.9, I have not tried it in 11.x. The license for Indoors resides in ArcGIS Pro. Open your online map from your Portal location in Pro. Go to the map properties and set the FloorAware fields. The Floor picker should show up. Save the map. 

View solution in original post

0 Kudos
4 Replies
KathleenCSki
New Contributor III

This worked in 10.9, I have not tried it in 11.x. The license for Indoors resides in ArcGIS Pro. Open your online map from your Portal location in Pro. Go to the map properties and set the FloorAware fields. The Floor picker should show up. Save the map. 

0 Kudos
JDenham
New Contributor III

This was one of the first things that I tried to do.  I naturally assumed that since all of the necessary floor-aware fields were there, it should simply require me to configure the map properly.  I have tried configuring these floor-aware fields both in Pro and Enterprise (new) Map Viewer.  The map layers are configured identically to how Pro does them during a direct publish.  Floor filtering works properly in the (new) Map Viewer itself, just not in Field Maps.  We have an active Indoors license, and use these floor aware maps regularly...just not with Field Maps because floor filtering does not work.

-J

0 Kudos
KathleenCSki
New Contributor III

I looked at Feild maps requirements and I think the issue maybe the Feature Layer Views. Editable data in field maps states it must be a Hosted Feature Layer with editing and sync enabled.  You might check with Tech Support on this. I know my Flooraware web maps using published from ArcGIS Pro using Hosted Feature Layers are working fine in Field Maps with the Floor picker widget.

0 Kudos
JDenham
New Contributor III

It turns out that I was missing a step in the documentation that details your above advice, and following some further testing this afternoon, I now have floor filtering working in Field Maps, even while using Feature Layer Views...as I hoped was possible.  Thank you for your willingness to help. 🙂

-J

0 Kudos