Cannot see related tables (M:N) in FieldMaps

443
0
02-25-2022 09:43 AM
Caitlin_Todd_LCOR
New Contributor III

Hello, 

I've set up a many-to-many relationship class from a table of people to a point feature for sites. Many sites to many people. This was created using the config in the screenshot "ManytoManyConfig" attached below. Some more details about it are:

  • Origin
    • Primary Key 'SiteGlobalID' is a guid type
    • Foreign key 'HistoryParentGlobalID' is a guid type
  • Destination
    • Primary Key 'GlobalID' is a GlobalID type
    • Foreign Key is 'ChildGlobalID' is a guid type

This created an empty intermediate table that needs to be manually filled out but that's not an issue. I filled out a subset of the table for testing purposes. The issue was after I published to AGOL as an editable hosted feature service, brought it into a web map, and opened it in FieldMaps. 

The layer shows the relationship correctly in the web map, one point layer, one related table, and the intermediate table. See screenshot "WebMapView". The pop-ups are set to show related features too.

But Field Maps only shows the point layer. See Screenshots "FieldMapsLayerList" & "FieldMapsPopup". The related records can't be seen or accessed from FieldMaps. 

I've tried adding the layer to a new map in both Map Viewer Classic and in the new Map Viewer. Same issue. 

FieldMaps troubleshooting log says "Found an Exploded Map Package" but I'm not sure what this error means. See screenshot "FieldMapsLog"

Using FieldMaps on iOS, FieldMaps version 21.4.0 build 607

Built the relationship class and layer with ArcGIS Pro version 2.9.1

Any suggestions for other things I can try are very much appreciated. Thank you, 

CaitlinT

0 Kudos
0 Replies