ArcGIS Online Field Apps Certificate Issue

09-15-2021 07:56 AM
New Contributor III


I am getting this issue at random times on Field Maps Mobile for ArcGIS Online.  It doesn't  happen to everyone but some people (2) are getting this on Android.  The services used in Field Maps aren't using sync in anyway, I am not sure how to fix this.




0 Kudos
2 Replies
Esri Contributor

Hi @JosephCarl2 


Thank you for sharing this issue with us. 

I see you're using Android. Which version of Field Maps do you have installed?

I understand that this issue happens at random times, but is there a consistent action that can reproduce it? i.e. when it happens, does it only happen when identifying a feature in the map, or can it happen simply panning/zooming around the map?

I understand that you're working in ArcGIS Online, however are the all the services in the map you're using hosted in ArcGIS Online? As oppose to ArcGIS Server?

When did you notice this issue start happening?



0 Kudos
Occasional Contributor II

@JosephCarl2 Here is the solution:


If you want the background to this here's an article describing what is happening: 

For an Android phone’s built-in browser, the list of trusted root certificates comes from the operating system — which is out of date on these older phones,” Let’s Encrypt explains. “However, Firefox is currently unique among browsers — it ships with its own list of trusted root certificates. This was a clue for us. Note the Sept 30th expiration.

Steps taken:

  • This was only impacting our Android devices; all other access to Enterprise is fine. Esri verified the health of the system, certs etc. Determined was IT issue.
  • Conferred with an Esri Partner that supports Esri client infrastructure & development and indicated several clients facing odd cert issues starting last night as well.
  • Within the Android device, only mobile apps faced this cert issue: 3rd party app, Field Maps, Collector. See attached error messages.
  • Using Chrome on the mobile device you could access the Portal site and authenticate just fine.
  • Using the ‘default’ browser (in my case ‘Samsung Internet’) you could NOT access the site and a similar certificate error displayed.
  • Tried installing Firefox app and making default in hopes that the apps would ‘look’ at the new Root certs but the behavior persisted.
  • iOS devices are not impacted.

Current workaround (your experience will vary a bit depending on your android version(s) and what browser you use on your desktop; Firefox used here did not try with other browsers):

Manually install R3 cert to device

  • From desktop: navigate to your portal URL and view, cert info click on padlock icon next to the portal URL
  • KellyArmstrong_0-1633032876350.png


    Click More Information

  • KellyArmstrong_1-1633032876456.png


    View Certificate

  • Click the R3 tab and scroll down to 'Miscellaneous' and download PEM(cert)
  • Get this to your Android device by your favorite means (email, file share, Drive, etc.)
  • Back on Android device: Settings>Biometrics & security > Other security settings> Credential Storage Install from phone storage> (on my device i select CA certificate, on other tablets it didn't have an option but import worked as expected; I didn't need to supply a name but they did and named it something appropriate)> maybe a warning > install the thing >reboot > open app and see if error clears.

This fixed Collector and Field Maps but so far not the 3rd party Esri app. I expect this may have far reaching impacts for Esri Partner devs.

0 Kudos