App says 'No Visible Layers' when trying to add feature.

2676
7
11-19-2020 12:50 PM
JasonJordan00
Occasional Contributor

So we are trying to get a start on migrating from Collector to Field Maps and are setting up our first map. We have an editable hosted feature layer, a template is set, the form is configured, and yet when we hit the '+' button in Field Maps it says 'No Visible Layers, Use the layer tool to toggle visibility'. However the layer is turned on and I can see, click on, and edit existing features. Any idea what I'm missing?

7 Replies
AlixPower
Esri Contributor

Hi Jason, I was wondering if you are able to share your web map with me? If you prefer too you can email it to me at apower@esri.com and we can communicate over email. 

0 Kudos
SaranyaKesavan
New Contributor II

Hi, Jason, can you add new feature to the same map with Collector? Can you try a map that works in Collector with Field Maps? 

0 Kudos
CinthiaEichhorn
New Contributor III

Hi Jason,  was there a solution?  I am seeing the same issue.  

Edit on 5/30 - My problem was that I updated domains using AGOL.  This was an empty dataset as it was in a testing phase.  Since I have been able to update domains in AGOL and not have problems with Collector, I thought this would be the case for Field Maps.  However,  over 4 different feature layers where I have updated the domain in AGOL, and then tried to use in Field Maps, I get the same problem.  Yet, no problems in Collector.   When I went to send the error, the issue was then showing as a 3079 error.  It appears the domain fix that happened in 2019 for Collector doesn't work with Field Maps. 

Only solution was to go back to Pro, add the domain updates there and overwrite as it each of the layers are currently in a testing phase.  

Also, just a side note that seemed odd: When I checked the logging in Field Maps it kept showing my layer wasn't floor aware.  Which was "new to me" error. 🙄

LindseyGordon
New Contributor II

Piggy-backing on Cinthia's comment - has there been any more investigation into this? I just discovered I'm experiencing the same issue both in Collector and Field Maps; I go to collect a point in a layer that should be editable, but the pop-up window says No Visible Layers. 

The architecture of my Field Maps stack is described in the attached .png. I have a hosted table joined to two separate hosted point feature layers via relationship classes that were originally published from ArcPro. Similar to Cinthia, I am using domains for certain fields - both of the hosted point feature layers use the same coded domain for the join field in the relationship class. However, I did not update the domain prior to attempting to use Collector/Field Maps, such as Cinthia describes. 

Interestingly, I can use Collector/Field Maps to edit features in the point feature layer in the map only if they are pre-existing. But it won't let me edit the coded domain join field (beekeeper OwnerID), which I should be able to do?

As it stands, I haven't found a solution or work-around to this problem.

0 Kudos
LindseyGordon
New Contributor II

Replying to my comment above to update with what I guess is a solution for my issue:

I learned that Collector and Field Maps really don't like it when you create relationship classes based on user-maintained relationships, such as I had done with my coded domain join field. Documentation  recommends creating relationship classes using GlobalIDs instead, so I re-architected my stack and re-published it to AGOL with the relationship classes now based on GlobalID/GUID. 

The stack includes 3 items:

  • Hosted Table of Apiary Owners (using GlobalID in the R.C.)
  • Apiaries Point Feature Class (using ParentGuid field in the R.C.)
  • Apiary Complaints Point Feature Class (using ParentGuid field in the R.C.)

The Apiary Complaints FC was empty, and the Apiaries FC had ~150 points in it, and the hosted table had ~50 entries. When I re-published to AGOL, I was still seeing the "No visible layers" error in Collector and Field Maps.

I tried re-uploading the stack, this time with completely empty point feature classes, and then appended my ~150 points into the Apiaries hosted feature layer after it was already published. This seems to have solved the problem - I am now able to successfully collect points in Field Maps/Collector.

I guess the take-away is that if you are going to be utilizing relationship classes in a Collector/Field maps configuration, make sure your feature classes are totally empty before publishing. 

 

0 Kudos
Cmyers_lawrencks
New Contributor

Just to jump in on this three years after-the-fact ...

I was able to solve this error, and it ended up just being related to the way relationship classes behave in the Field Maps app. The issue ended up being that if you have a relationship class defined between two layers, Field Maps (and I am assuming Collector is the same) will only allow you to ADD additional features if you go through the EDIT window of the associated "parent" feature. So, for example: I was working with two layers; inspection sites (parent; point) and hazard locations (child; point). There was a many-to-one "composite" (as opposed to "simple") relationship between the hazards (many) and the sites (one) that got passed up into our ArcGIS Online Hosted Feature Layer. When I wanted to interact with the hazard points in Field Maps, and I chose to tap the big blue + button in the UI, I would always get the "No visible layers" message. But, if I tapped on an existing "site" point and then clicked through the LINK icon while editing (it appears as a length of linked chain pieces), I could then add an associated hazard point to the site. 

For my team, this was unfortunately a deal-breaker as this would mean our field crews would need to move through a longer and more complex process "per-hazard-point." We wanted just a single click to get through to adding a hazard, but this new dependency would mean that each hazard point would require 5 clicks through multiple screens: 1. selecting the site; 2. opening the links panel for the site (chain button); 3. the chain button again for some reason; 4. selecting the linked hazards layer; 5. tapping the "add" button; and then finally choosing the hazard type and entering the point info. 

It must be acknowledged that if the relationship class is set up as a "simple" relationship ... Field Maps will still behave the same way. That is, the app will require you to "click through" the "one" of the "one-to-many" relationship in order to add the "many" features. In my case, this means the hazards. 

0 Kudos
Brady
by
New Contributor III

I have this issue and it is annoying as. I found this solution. I have just tested it and it works for me.:)

Problem: The message 'No Visible Layers' is displayed in ArcGIS Field Maps

 

0 Kudos