how to adjust the layout view to fit with dataframe and vice versa

5994
4
10-11-2017 02:47 AM
HelgaGomes
New Contributor II

Hi, As a beginner I am having a lot of problems with Data Frame and the Grid. When I started to draw these maps my entire map fit quite nicely into the layout view and so then I used Export Map I got Figure 1 wherein the entire layout view area was covered by my figure. Bu then I realized that i had missed some points on the east so I extended my figure eastwards. In doing so I got a lot of bank spaces in the north as the map was extending both X and Y axis proportionally. So I used Data Frame Properties ->Fixed Extend and Chose about 13.5 degrees in the north. Now the figure was shortened to about half of the layout and when I exported it it looked very small with a lot of blank spaces around it. I tried to go back to my old layout but I couldnt do that either.

Any help would be much appreciated.

Thanks a lot!

Helga

0 Kudos
4 Replies
XanderBakker
Esri Esteemed Contributor

Hi Helga Gomes ,

Make sure you are in the layout view:

Select your dataframe, right click and select the option "Properties" to access the dataframe properties:

Activate the "Data Frame" tab and select "Automatic" Extent:

Activate the "Size and Position" tab and specify the correct values. Below an example of A4 paper size an dleaving 1cm margin to all sides:

Go to you table of contents, select the layer that has the largest extent, right click and select "Zoom To Layer":

HelgaGomes
New Contributor II

Hi Xander,

Thanks a lot for your response which seems the most logical but I seem to have one other problem which is that when I give the Size (width and Height in inches) it automatically adjusts the the Aspect Ratio so the figure becomes very large. This seems odd as the Aspect Ratio is greyed out (see Figure attached). also I cant access the Zoom to Layer as that too is greyed out for all the layers in my mxd file.

Any help will be much appreciated.

Thanks

Helga

0 Kudos
XanderBakker
Esri Esteemed Contributor

Are you sure the extent is set to Automatic (no fixed extent anymore)?

HelgaGomes
New Contributor II

Hi Xanders,

Thanks for your reply. I finally got to the point where I could actually uncheck the Aspect ratio option. I right clicked the layer, Properties-> Data Frame Properties-> Data Frame _>Changed to Automatic. Then I hit Apply and OK. Then I went back again : Right clicked the layer, Properties-> Data Frame Properties-> Size Position. Changed it to the size I wanted.

Then Zoom to Layer and it worked! I think getting in and out of Data Frame Properties somehow worked for me. I really have a lot of flexibility to display my maps now!!