AGX 2500 Layer package not opening from Windows Explorer

2508
3
02-19-2013 05:07 AM
AnthonyJones2
New Contributor II
I am having problems opening layer packages in AGX 2500.  Typically we would open a layer package by double-clicking on it in Windows explorer.  This launches AGX 2500 which means the file association is working.  But when AGX opens, I just see the basemap and nothing from the layer package itself.  Yet if I then use "Add Content" and add the same layer package, everything displays as expected.  This worked in Build 1750.

Does anyone else see the same behaviour?
0 Kudos
3 Replies
LucasDanzinger
Esri Frequent Contributor
I'm getting some strange behavior. First, I am assigning the File Handler to Explorer for layer packages here: C:\Program Files (x86)\Common Files\ArcGIS\bin. Then, when I double click, the first time, I typically get an error and Explorer eventually opens with no data. I can see that the package is unpacking, however. Then, if I double click again, sometimes it opens successfully and sometimes nothing happens. I'll let you know as I find out more.
0 Kudos
LucasDanzinger
Esri Frequent Contributor
I submitted a bug for this- NIM089244: Layer packages do not open in ArcGIS Explorer Desktop 2500 when the package is double clicked in windows explorer, if ArcGIS Explorer is not running.
0 Kudos
RickGeittmann
Occasional Contributor II
I had the same issue - tried loading OS patches etc to no end.

The fix (at least for us)  I found which does not require admin rights is to simply open Windows FILE EXPLORER navigate to the MY DOCUMENTS and delete all files under the ArcGIS Explorer directory and in the ArcGIS directory IF ONLY ArcExplorer is loaded on the machine - if you have any Arc Desktop software loaded delete only those files under the ArcGIS Explorer directory.

Reopen ArcExplorer navigate to the NMF you want to open and it should work.

The symptoms we had were a user would double click on a NMF file and the application would just sit there with a screen up indicating that it was loading the NMF file but would never open it.

Some machines we did not have this issue on though.

Hope this helps
Rick
0 Kudos