Select to view content in your preferred language

Unable to add utility services

1108
3
Jump to solution
06-13-2023 12:35 AM
Thomas_Fuhrmann
New Contributor III

Hi all,

I'm trying to add a utility service to an Experience Builder app, but when I click on my custom print service or any other service, it gives me the following error:

This utility service is not supported.

I'm using ArcGIS Enterprise 11.1.

1 Solution

Accepted Solutions
DanJiang
Esri Contributor

Hi @Thomas_Fuhrmann , 

Could you check if your service is a supported service type? And please make sure the printing service URL should include the task level, such as https://sampleserver6.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%... 

View solution in original post

0 Kudos
3 Replies
DanJiang
Esri Contributor

Hi @Thomas_Fuhrmann , 

Could you check if your service is a supported service type? And please make sure the printing service URL should include the task level, such as https://sampleserver6.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%... 

0 Kudos
Thomas_Fuhrmann
New Contributor III

@DanJiang Thank you, it works when I add it via its URL. The problem was just that I wanted to add the item listed in the "Items" tab under "Add utility". Now I see that the problem is that the item listed under the "Items" tab links to the print service and not to the Export Web Map task.

0 Kudos
DanJiang
Esri Contributor

Glad to know the problem is solved!

0 Kudos