unable to add menu widget to header

249
1
09-02-2020 10:17 AM
MarshallKeeney
New Contributor

Hello, I'm working on my first experience with Experience Builder and have made several pages with content for this experience.  I'm next trying to add a menu widget to the header to navigate to the pages.  After clicking "Edit header", i am not able to drag & 'drop-in' any widget to the header. I also notice the "Choose a page template -OR- drag a widget here" message is not showing up.  Is there a setting to lock the Header that I've accidentally selected?  Or anything else i'm overlooking that wouldn't allow me to edit the header? 

I tried making a copy of the experience, but the problem remains.  I tried making a template and create a new experience, but I was unable to use My Templates to create a new experience (i'm not sure why).

I see two workarounds, 1) create a custom row at the top of each page with desired menu widget, but this won't be a true header or 2) recreate the experience but configure the header early on before the Experience is packed with content.

Thank you for reading.

Any help is appreciated,

-Mars

1 Reply
Amanda__Huber
Regular Contributor

Marshall Keeney‌ unfortunately you're not alone, our organization is also facing this issue with one of our Experiences. We currently have an Esri case open (case #02627512) documenting this behavior but we're trying to pinpoint the cause of the issue. Here is what our experience looks like in comparison: 

The header does not prompt for the typical "add widget" prompt (per your screenshot) and does not allow for any widgets to be added. 

ArcGIS Experience Builder‌ team, any ideas why this is happening to us? 

Thanks, 

Amanda