Survey123 Widget in Experience Builder - Why Can't Others See Surveys?

714
6
03-20-2023 02:07 PM
Labels (1)
TSWCD_GIS
New Contributor III

I have an experience builder site setup with the Survey123 widget. Survey data is in the map and viewable through other widgets in the site, but the Survey123 widget has the message in the attached image for any organizational account other than my own. The survey, data, maps...everything is shared on the organizational level. Did I miss a setting to make sure other users could view surveys in the widget?

0 Kudos
6 Replies
Richard_Purkis
Esri Contributor

Hi @TSWCD_GIS 

Thanks for raising this with us.

From a first glance, it is likely the survey has not been shared to other people. Please refer to the following technical article which guides you through the steps to do this as one of the solutions:

If that doesn't resolve your issue I recommend you reach out to Technical Support.

Hope this helps

TSWCD_GIS
New Contributor III

Thanks for the reply @Richard_Purkis , the survey is shared within our org and no one has issues using the survey itself through the Survey123 app. I attached a screenshot of our sharing setup based on that tech article you linked. Sounds like I need to get in contact with tech support.

0 Kudos
Richard_Purkis
Esri Contributor

Hi @TSWCD_GIS 

I'm sorry to hear that didn't resolve your issue.

Essentially some part of the survey widget is requesting access to a layer that isn't shared with the respective user. If it isn't the survey target layer itself it must be another layer.

Tech support will be able to dig a little deeper

Hope this helps

0 Kudos
cdevault_pickett
New Contributor III

Hi @TSWCD_GIS. Were you ever able to get this resolved? I have a Experience Builder app with an embedded S123 form that suddenly started doing the same thing that was described by @Richard_Purkis.

0 Kudos
cdevault_pickett
New Contributor III

For whatever it is worth, the issue I was having here seemed to go away on its own the next day.

0 Kudos
ZhifangWang
Esri Regular Contributor

Hi @cdevault_pickett ,

Thanks for sharing the result and good to know it works for you.

For the error message in the screenshot in the original post by @TSWCD_GIS ,

You do not have permission to view this survey record.

This means the Survey widget is used in the view mode (vs. normal submit mode) to view a specific record in the result layer, however, the user who opens this web page does not have privilege to see the record. For example,

  • The user does not have access to the feature layer that stores the submitted record.
  • Or the user can access the record, but the layer is configured "user can only see the record submitted by themselves" and the specific record is submitted by another user.

Related settings are suggested to configure via Collaborate->Share results (not Share survey) tab on the Survey123 website or if you are familiar with feature layer, you can configure the underlying details on the item details page of the feature layer in ArcGIS Online.

 

 

0 Kudos