Single Sing-On Experience with Enterprise Login

1446
7
11-23-2020 07:48 AM
Labels (1)
Ranga_Tolapi
Occasional Contributor II

ArcGIS Portal (v10.8.1) is configured with Enterprise login (Azure AD) and it’s the only Sign-in option made active in ArcGIS Portal. Single Sign-On was verified successfully with ArcGIS Portal against Azure AD.

 

Our web application is developed in ArcGIS Experience Builder, deployed on web server (IIS) as per https://developers.arcgis.com/experience-builder/guide/deployment-topics/

 

Our web application is using a web map from ArcGIS Portal which is shared to only “Organization”, thus it needs to be allowed only after authentication.

 

For every attempt we make to launch our web application, challenged by 2 dialogs, 1st one is for sign-in and 2nd one is for permission. Please refer to the enclosed screenshots.

 

This is happening for the 1st attempt and all the subsequent attempts in the same browser (Google Chrome), different tabs. Even two consecutive attempts in the same browser’s different tabs have this behavior.

 

Screenshot-1

Ranga_Tolapi_0-1606146101994.png

 

Screenshot-2: This is appearing when clicked OK in Screenshot-1

Ranga_Tolapi_1-1606146101997.jpeg

 

These both dialogs were impacting smooth Single Sign-On user experience for our web application. How to suppress/handle both the dialogs?

0 Kudos
7 Replies
BillFox
MVP Frequent Contributor

Hello Ranga,

Is that webmap pointing to an ArcGIS Server service or a hosted item?

Federated?

Built-In > Shared user name and password when published?

Where is AEB at?

0 Kudos
Ranga_Tolapi
Occasional Contributor II

Hello BillFox,

 

Please find my response below. Thank you.

 

Is that webmap pointing to an ArcGIS Server service or a hosted item?

- Webmap is pointing to hosted item.

 

Federated?

- Yes, federated.

 

Built-In > Shared user name and password when published?

- Webmap is a portal item pointed to federated ArcGIS Server. Webmap was shared to "Organization"

 

Where is AEB at?

- AEB is in my laptop. ArcGIS Portal is on Azure (IaaS), which can be connected from my laptop.

0 Kudos
WeiYing1
Esri Contributor

Hi @Ranga_Tolapi ,

Thanks for your feedback. But the behavior you described should be as expected. It is designed by js-api. 
The first popup as above Screenshot-1 shows with OK/Cancel is actually to ask browser to allow actual login popup, which is as Screenshot-2.  Since sometimes browser will block popup, the popup (screenshot-1) is to ensure the correct display of actual login page (screenshot-2)

0 Kudos
Ranga_Tolapi
Occasional Contributor II

Noted with thanks @WeiYing1 

0 Kudos
Ranga_Tolapi
Occasional Contributor II

Is there a way to get rid of Sign in dialog and Permission popup for subsequent attempts? Means, after successful authentication, when opened the web application in a new tab (same browser) both dialogs appearing again. Expecting a behaviour like Keep me signed in option for Enterprise log in.

 

@DavidMartinez 

0 Kudos
HarshvardhanSwami-Provista
New Contributor

Hi @Ranga_Tolapi ,

Greetings!

I am facing the same exact issue, where I am getting the two dialogs which is disturbing my smooth single-sign on experience. Have you find any solution to this? Can it be done programmatically?

Best regards,

Harsh

0 Kudos