Search List and Search Widget Bug?

1132
4
Jump to solution
02-22-2022 09:37 PM
LaurenMiller78
New Contributor III

Hello,

I am having issue with the search functionality, both in the search widget and search within in a list.  I have an application which uses a list and map (Jewelry Box template).

When a user types in a search term and hits ENTER rather than selecting a term from the list of results, strange behavior is observed. 

Example:

I type the word "watertender" into the search (list or widget). I select "watertender" from the results list. The list and map narrow to just those records which contain the word "watertender" in the search fields I identified, as expected.  I select one of these narrowed records from the map or list.  Once the record is selected, I can click another button to go to a view (feature info widget of selected records).  This is the desired behavior.   

I type the word "watertender" into the search (list or widget).  Instead of selecting the word watertender from the list of choices, I hit enter.   The list and map narrow to just those records which contain the word "watertender" in the search fields I identified, as expected.  However, when I select one of these narrowed  records from the map or list, the record is selected for a split second, then it is unselected.  A user cannot trigger any further agains because they are dependent on a record being selected.    

I stripped all of the list and map actions away and the problem still persists, so I am fairly certain this is a problem with searching.

I GREATLY appreciate any advice - this is make or break type behavior for this application.    

0 Kudos
1 Solution

Accepted Solutions
JonathanMcDougall
Occasional Contributor III

Hi,

Unsure if it's "make or break", bit melodramatic.

I suppose what needs to be understood is what happens when a user hits enter on a partially completed search, its relationship with the records held in your data, along with the behaviour of the map. Also curious, if all actions have been stripped, when you're saying the problem persists as there's no relationship between map and list.

Perhaps what we first have to discover is how you've setup the actions between list and map, map and list. Have you also switched on the "Exact Match" from the list search?

I've created a very rough example, just to tease out what you have setup in the back.

https://experience.arcgis.com/experience/b33919e245554101aa2dd777d672cd91/

So, in above, if you type in Stir, incomplete for Stirling, and hit enter - all records are shown for Stirling. Select a record from the list, the action is to zoom to. For this example I've also set the map to filter the list on extent change. Just remember, if a search filter is applied and you move to another town, the list will return zero. (Map has deselect button active).

It's easy to get over zealous with actions, they are very handy but can cause issues when you "cross the streams".

Can you elaborate more on what you've actually set up, please?

View solution in original post

0 Kudos
4 Replies
ShengdiZhang
Esri Regular Contributor

Hi @LaurenMiller78 ,

I can't reproduce your issue, can you share your app and data with me? My user name is she10946.

Thanks,

Shengdi

0 Kudos
LaurenMiller78
New Contributor III

Thank-you for your speedy response and willingness to engage.  I realized this morning that the issue was "case sensitive" which was also very strange.  In other words, if I use the word "Watertender" rather than "watertender", the problem did not occur.  However, @JonathanMcDougall 's response led me to put the data into a new application to see if the issue persisted.  It did not, so it must be related to one of my views.  The list in my application is one of 3 views in a section.  When a user selects a record in the list, they are taken to the feature info widget which shows the pop-up of the selected record.  There was a competing action in the feature info widget.  The case sensitivity is a mystery, but I am happy the search is functioning!            

0 Kudos
JonathanMcDougall
Occasional Contributor III

Hi,

Unsure if it's "make or break", bit melodramatic.

I suppose what needs to be understood is what happens when a user hits enter on a partially completed search, its relationship with the records held in your data, along with the behaviour of the map. Also curious, if all actions have been stripped, when you're saying the problem persists as there's no relationship between map and list.

Perhaps what we first have to discover is how you've setup the actions between list and map, map and list. Have you also switched on the "Exact Match" from the list search?

I've created a very rough example, just to tease out what you have setup in the back.

https://experience.arcgis.com/experience/b33919e245554101aa2dd777d672cd91/

So, in above, if you type in Stir, incomplete for Stirling, and hit enter - all records are shown for Stirling. Select a record from the list, the action is to zoom to. For this example I've also set the map to filter the list on extent change. Just remember, if a search filter is applied and you move to another town, the list will return zero. (Map has deselect button active).

It's easy to get over zealous with actions, they are very handy but can cause issues when you "cross the streams".

Can you elaborate more on what you've actually set up, please?

0 Kudos
LaurenMiller78
New Contributor III

Thanks for your speedy reply.  Your mock-up was very helpful. 

I did strip the actions between map and list, but still had selection enabled so that records selected in the list showed in the map.   As you suspected, the issue was a competing action - not in the map or list, but in the feature info widget.  The list is one of 3 views in a section.   

0 Kudos