ProxyPass to expose Experience Builder to the web without showing port 3001

211
2
05-26-2022 10:41 PM
Clowie
by
New Contributor

Hi All,

We are working on building Experience Builder applications and one of the vital parts of this service for us is to seamlessly present these applications as part of our web architecture. We are currently using Apache to deliver our web services.

How it currently works. => Address bar `https://subdomain.ourdomain.com:3001/experience/0/`

How we want it to work = > Address bar `https://subdomain.ourdomain.com/`

I would usually use ProxyPass for this, but I'm running into errors of `Proxy Error 502 "Reason: Error reading from remote server"`

Has anyone been able to property reverse proxy the experience builder app to route from standard ports :80 and :443?

0 Kudos
2 Replies
UalasRohrer
New Contributor III

I was able to reverse proxy using Caddy. Note that you need to disable https in the experience builder in order to get Caddy's https working.

Clowie
by
New Contributor

Thanks @UalasRohrer, that's some good info. We're hosting with Apache (I've updated my post to include that information) so a solution with Caddy isn't going to help me with this one. But it does make me feel more confident that it should be working with Apache.

Were there any unusual steps you needed other than disabling https in experience builder?

0 Kudos