Pop-ups in Experience Builder Preview

2140
8
Jump to solution
12-06-2019 08:03 AM
NoahMiller
New Contributor II

I've been having an issue getting pop-ups to work in the Experience Builder. I can configure and use pop-ups in the viewer. When I try clicking on an object in the Ex. Builder the app loses most functionality like panning camera, zooming, loading layers. (Tried in Chrome, and Firefox/Firefox Dev.)

  • Note: Everything else works, I can load my web maps, layers, and all map functionality works until I try and click an object to open a pop-up.
  • The map is shared publicly https://arcg.is/aH4mS 
  • The TIF Districts and HUC14 WEB are the layers that have pop-ups enabeld.
0 Kudos
1 Solution

Accepted Solutions
NoahMiller
New Contributor II

David,

Sorry for the delayed response. I was able to troubleshoot and figure out it was an issue with one of our services. Not the experience builder itself. 

Thanks again for taking the time to work with me.

Noah 

View solution in original post

0 Kudos
8 Replies
DavidMartinez
Esri Regular Contributor

Hi Noah,

Are they any special configurations for this popup? Can you share the webmap? 

0 Kudos
NoahMiller
New Contributor II

David,

Here's a link to the map: https://community.esri.com/external-link.jspa?url=https%3A%2F%2Farcg.is%2FaH4mS  

it should have the layer displayed with the pop-ups enabled. When I launch a preview in the Experience Beta it throws a an error in the console saying it can'y read the properties. Was wondering if there was a known issue with pop-ups.

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi Noah,

I was able to get the webmap to load in an ExB application. The only errors I do receive are spatial reference ones. Are you still have problems with this webmap? Currently, we do not have any known issues with popups. Are you using the online version of ExB or developer edition? What template did you use in ExB and what type of settings etc.? Trying to see if I can reproduce this. 

Popup

Thanks,

David

0 Kudos
NoahMiller
New Contributor II

David,

 I haven't modified any of the original files yet. I answered your questions below.

  • Are you still have problems with this webmap?
    • The web map itself is fine, Pop-ups work in the viewer. Its when I try to view a pop up in the ExB and click on geometry it throws an error in the console and I lose map functionality. I haven't modified any settings in regards to the pop-ups other than enabling them.
  •  Are you using the online version of ExB or developer edition?
    • Developer Edition from the second Beta Release
  • What template did you use in ExB and what type of settings etc.?
    • Using the Vivid Template, The only change I've made is setting up a a custom base-map group so I can load our base-maps in the base-map gallery widget. I also changed the default map to the topo base-map in the group to set the extent.

Hopefully this describes the error a little bit better. Let me know if you have any further questions.

Thank you!

-Noah

*added map after default in last bullet

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi Noah,

What browser are you using? Also, can you create the ExB app and share it publicly with me? I can use the data source as a webmap in ExB and I can click on the geometries without any errors.

Thanks,

David

0 Kudos
NoahMiller
New Contributor II

David,

Sorry for the delayed response. I was able to troubleshoot and figure out it was an issue with one of our services. Not the experience builder itself. 

Thanks again for taking the time to work with me.

Noah 

0 Kudos
ClaudiaFries
New Contributor II

Hi Noah,

sorry for a question out of topic: Just had a look on your shared public web map.

How did you manage the grouping in the table of content?

I understood, that only map viewer beta allows to group layers, but your map looks like the "normal" map viewer.

Many thanks in advance and sorry again for being out of topic.

Claudia

0 Kudos
NoahMiller
New Contributor II

Claudia,

Sorry for the late response. I'll start off by saying I'm a web developer first, GIS specialist second. We use a rest endpoint to host all our services/feature classes. The Septic WEB Feature class was structured that way when it was built. I did nothing to it other than link out to it from our rest endpoint. The organization was inherit and wasn't modified in the experience builder. 

You can see the full service here: Engineering/Septic_WEB (MapServer) 

Noah

0 Kudos