Performance Lag for filter options /map updating/ feature info.....worked better spring 2022 than now?

08-17-2022 01:03 PM
Labels (1)
Occasional Contributor III


I have been working on EB app which includes a point feature layer in AGOL with ~37,000 points. Currently within the EB there is a web map (framework set to filter records), filter widget, feature info, and list. I haven't looked or worked with this app since last spring and now I just keep experiencing lags in the data/filter lists (showing up) and map updating to show filtered data. To the point I need to move the map at times for the points to actually filter? The overall performance seemed much better last spring?

I did see a few other posts about slow performance after the last few updates. Have others noticed this? 

I'm trying to get the EB ready for folks to review, but at the moment I think folks will be confused when they click to filter the data and get the 'No data' option (see attached) but then it will populate a list of options later? For example in the attached, you can see for the filter 'Release Age' had previously given the option of 5, but now when I click to change the filter 'No data' is shown. I also have a lag in that the feature info sometimes show's No data even though points are on the map. There is also a dynamic count of records that shows or updates with the map/filters and now there is sometimes a discrepancy between the feature info and this total. 

I had seen this post on performance issues and they had redid all their widgets to improve performance, but that seems like such a pain.

VERY slow pop-up performance in Experience Builder - Esri Community

I don't understand what is going on but if I don't then folks reviewing it will really be confused and not impressed.

One change I did make was to set the 'Clear all filters' option in the filter widget  (which I was really excited about) not sure if that has messed with anything behind the scenes, but now after the clear all filters. All the filters get the 'No data' option for applying a filter?  I just don't remember getting the 'No data' option so often.

I'm curious if others are having issues or noticing performance changes.



0 Kudos
0 Replies