Select to view content in your preferred language

Map Zooms to 0,0

571
1
Jump to solution
11-15-2022 07:25 AM
Labels (1)
ZachBodenner
MVP Regular Contributor

Hello,

I have a relatively simple Experience with a Map, List, and some text/picture widgets. The map has a single layer which is used in the list and text widgets. I have a Message Action that should trigger the map to zoom to the selected feature when it's clicked on in the list widget. However, the map zooms to 0,0. I have not been able to figure out why this is happening (I have a similarly simple Experience with the same list-to-map zoom function, which works just fine.)

Experience Builder Developer Edition v1.9, AGOL

0 Kudos
1 Solution

Accepted Solutions
ZachBodenner
MVP Regular Contributor

So I had previously read some other posts on the community that said projecting the data into web mercator solves this problem. I didn't really want to do that because we have all of our internal data in the same coordinate system. I tried just setting the coordinate system of the Pro map used to publish the data, and that actually did the trick. Hopefully that helps someone else!

View solution in original post

0 Kudos
1 Reply
ZachBodenner
MVP Regular Contributor

So I had previously read some other posts on the community that said projecting the data into web mercator solves this problem. I didn't really want to do that because we have all of our internal data in the same coordinate system. I tried just setting the coordinate system of the Pro map used to publish the data, and that actually did the trick. Hopefully that helps someone else!

0 Kudos