Select to view content in your preferred language

Fails to install Arcgis experience builder for developers Edition (ERRORRRRRRRRRR)

1719
6
Jump to solution
10-26-2023 12:59 AM
Labels (2)
KARIMLABIDI
Occasional Contributor

Hello,
i'm trying to install the Arcgis experience builder for developers Edition and it doesn't want :). I have followed this link http://www.davidapps.net/exb/EXBDevTutorial/overview.htm?ms=EgAQEg%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw... it's ok for the server but the client not.

I get messages with node or python Errors and I don't where it comes.

So if someone could help me 🙂

AEB1.JPGAEB2.JPG

2 Solutions

Accepted Solutions
JeffreyThompson2
MVP Regular Contributor

https://community.esri.com/t5/arcgis-experience-builder-questions/issue-with-the-installation-of-the...

You aren't the only one having this problem. Please contact ESRI support and tell them that there is a dependency issue in their node packages. No one will be able to install Developer Edition until they issue a patch that resolves this problem. @AzizaParveen1 @Jianxia @TonghuiMing 

GIS Developer
City of Arlington, Texas

View solution in original post

TonghuiMing
Esri Regular Contributor

@JeffreyThompson2 It seems to be a node-sass installation issue in the environment where the installation happened. We will log an issue to document it.

View solution in original post

0 Kudos
6 Replies
JeffreyThompson2
MVP Regular Contributor

https://community.esri.com/t5/arcgis-experience-builder-questions/issue-with-the-installation-of-the...

You aren't the only one having this problem. Please contact ESRI support and tell them that there is a dependency issue in their node packages. No one will be able to install Developer Edition until they issue a patch that resolves this problem. @AzizaParveen1 @Jianxia @TonghuiMing 

GIS Developer
City of Arlington, Texas
KARIMLABIDI
Occasional Contributor

Hello @JeffreyThompson2 , I resolved the problem with my IT. We have downloaded node.js 18, install Visual Studio, reinstall Python, and it works. I can't explain, i don't understand at all but it works 🙂

JasonBOCQUET
Occasional Contributor III

Hi, can you tell me where you find the v18 of nodejs ? on the official website i can find only the 20.9 v

 

thanks !

0 Kudos
TonghuiMing
Esri Regular Contributor

@JeffreyThompson2 It seems to be a node-sass installation issue in the environment where the installation happened. We will log an issue to document it.

0 Kudos
JeffreyThompson2
MVP Regular Contributor

https://community.esri.com/t5/arcgis-experience-builder-questions/npm-ci-command-throws-error-in-cli...

Another user with this problem. And at the same time, I was installing Experience Builder for a client and also hit this error. I was able to resolve it for my client by uninstalling Node 20.1 and installing Node 18.16.

GIS Developer
City of Arlington, Texas
clc
by
New Contributor III

Thanks a lot for the advice on downgrading to Node 18.16. I have now ExB 1.13 finally working!

0 Kudos