Select to view content in your preferred language

Experience Builder Edit Widget not Synching to Selected Features

309
1
07-31-2023 08:15 AM
GraceOh
New Contributor

I am developing an app in Experience Builder to edit multiple different data sets across multiple pages. I have the screen configured with a list widget, map, and edit widget with corresponding actions set up so when a data point is selected in the list or map the framework selects that specific data record. With the first data set this connection meant that when a point was selected, the edit widget automatically opened that record to be edited. This is the desired behavior across all data sets. When I attempted to establish this connection with the other data sets, the edit widget fails to respond to the feature being selected in the map or list, so the only way to edit the point is by first choosing the select tool within the edit widget. Is there some reason why the automatic link to the edit widget is working with certain data sets and not with others? Am I missing a step in how to link all of these widgets? All of the data is editable and all of the actions are the same across the different data sets, the only difference between the pages is the data itself. 

 Screenshot 2023-07-31 105107.pngScreenshot 2023-07-31 105118.pngScreenshot 2023-07-31 105133.pngScreenshot 2023-07-31 105142.pngThe first two images are from the first page that is working correctly, the second two are from the page that is not functioning as intended.

0 Kudos
1 Reply
TianWen
Esri Contributor

Could you provide a sample app for the team to investigate it?

0 Kudos