Experience Builder Developer Edition 1.5 - source data from map not available to query widget

809
10
Jump to solution
08-25-2021 12:44 PM
DavidColey
Frequent Contributor

Hi - does anyone know why a source layer selected from your experience builder developer 1.5 edition map would not be available to the query widget, when the same layer is available to the layer list widget?


I have an source webmap built from/in map viewer beta on in our 10.9 portal.


The layers and webmap are all public.


The layers are all available to the layer list widget, and so when I deploy the app to my webserver, I do see all the layers.


BUT, a Street layer for Query Widget, selected from the map as the data source, is NOT available to the query widget. I get a whole host of jimu errors when I open the query widget:

DavidColey_0-1629920634122.png

This could not be a more simple deployment.  I'm just trying to get some simple things resolved before trying to add in custom widgets and code.  It shouldn't even require a client id because everything is public.

@DavidMartinez  perhaps you have seen this??

0 Kudos
1 Solution

Accepted Solutions
Junshan_Liu
New Contributor III

@DavidColey The jimu-for-builder package is not included in the download package, this bug will be fixed in next release. To workaround this bug, can you try to copy this package from client/dist folder to your deployment folder to give it a try?

View solution in original post

10 Replies
DavidColey
Frequent Contributor

As a follow-up and as a test for whether or not anonymous access has an effect on this issue, I registered the 1.5 Exb with our ArcGIS Online organization.  I created a simple jewelry box theme app with one layer and one query. 

As I noted earlier, while the data source is available to the map, mapview, layerlist and legend, the load fails for the Query Widget.  I am beginning to suspect an issue with the 1.5 version, as I receive the same load module errors. Maybe some of the modules are being compiled once I download the zip.  I don't know. Everything works in EB Dev, it only fails once deployed to my standard IIS webserver

here is a link to try for yourselves:

https://ags3.scgov.net/thorofareagol

@DavidMartinez 

@jcarlson 

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi David,

I am adding a couple of my colleagues to take a look @Junshan_Liu  @TianWen. I  switched core teams back in May and I haven't been working on ExB since then. 

Cheers,

David

DavidColey
Frequent Contributor

Ok thanks David

0 Kudos
Junshan_Liu
New Contributor III

Now, Exb data source does not support all types of layers. If you data is public, can you post it so we can take a look?

0 Kudos
DavidColey
Frequent Contributor

Yes hello @Junshan_Liu .  I am working with a simple hosted feature layer from Enterprise 10.9.  In this application:

https://ags3.scgov.net/thorofareagol

the feature layer can be found here as an agol item:

https://sarco.maps.arcgis.com/home/item.html?id=3f854ed4c2684ae89b3aa54c2c424c21

The layer does come from a referenced collaboration.  I host my feature layers on our portal, and send to arcgis online in a distributed collaboration.

 

 

0 Kudos
Junshan_Liu
New Contributor III

Hi @DavidColey I can't access the app. However, I tried the layer, it works well, and the query widget can use it.

0 Kudos
DavidColey
Frequent Contributor

Thanks for looking into this @Junshan_Liu .  You should be able to access the application, it is fully public unless you have something on your end that is preventing you / blocking our ags3.scgov.net domain. (It its public, we are a county government) . 

Regardless, yes the layer works just fine in the Experience Builder Dev Edition 1.5 at design time / build time and I am glad you found the same.

However, when 'downloading' the published app to zip, unzipping it to our web server, the published / built app at https://ags3.scgov.net/thorofareagol (...\inetpub\wwwroot\thorofareagol\cdn\0) cannot access some of the libraries, and the query widget does not function:

DavidColey_0-1630072220198.png

DavidColey_1-1630072307624.png

So either the Dev Edition at 1.5 is not downloading / compiling the built app / query widget correctly, or I have another security issue with my web server or IIS.  To me, if the layer is available to the layer list widget, it should not have an issue with the query widget.  

Thanks

0 Kudos
Junshan_Liu
New Contributor III

@DavidColey The jimu-for-builder package is not included in the download package, this bug will be fixed in next release. To workaround this bug, can you try to copy this package from client/dist folder to your deployment folder to give it a try?

View solution in original post

DavidColey
Frequent Contributor

Yes @Junshan_Liu  that did it.  Thanks for the help on this, I would not have known to look there otherwise. 

If I understand this correctly, I had the client/jimu-for-builder copied over to my deployment, not realizing that this folder essentially functions as the 'build-time' repository' ts files needed by the builder, whereas I suppose the client/dist/jimu-for-builder holds the 'runtime' js needed by the apps upon deployment.  My guess too is if a custom widget does not load to check this as well-

@RobertScheitlin__GISP 

0 Kudos