Experience Builder Constantly Crashing

2198
10
04-28-2022 08:20 AM
Labels (1)
MelanieWilliams1
New Contributor III

Has anyone else had issues with Experience Build crashing on a regular basis?  

For us, this has been happening off and on for several months now.  We get both error of "not enough memory" and "something went wrong" from the browser.  Mostly work in Chrome but this happens in Firefox as well.  It doesn't seem to matter if it is a complex project or ones with a simple map and few other simple widgets.  We have also tried closing all other programs on our machines when this occurs.  

Various troubleshooting efforts have been tried to figure out if there is a particular widget, dataset, browser, or complexity level of a project that might be causing the issue.  However, we have had no luck.  It is also not consistent from day to day.  Co-worker had it crashing ever few minutes yesterday and I was working for several hours with only one crash.  This morning, I'm working in the same project and it's crashing about every 3 to 5 minutes.  

Does anyone else experience?

10 Replies
jcarlson
MVP Esteemed Contributor

Are you running the web version, or hosting something you built with Experience Builder Dev?

Also, is it the Builder that's crashing, or the experience that you've built with it?

- Josh Carlson
Kendall County GIS
0 Kudos
MelanieWilliams1
New Contributor III

Good questions.  We are working in the web version.  

What we have been seeing is that it crashes in both the builder itself as well as the published app.  Hope that it's somehow isolated to us, we have had others test the published items and they experience the same thing.  The odd part is that you can go into the build editor and the published item days later and it may only crash once or twice or not at all.  The (what seems like) inconsistency to this has really thrown us off.  

0 Kudos
HarmondSantos1
New Contributor III

We're having this issue as well at the moment. The experience I've created contains a number of dashboards in it. The team has been getting "Out of Memory" or "Something went wrong" error messages. Initially, I had them toggle between different browsers but it doesn't work anymore. It crashes on any browser now. Has anyone been able to identify the cause and a workaround for this? Thanks! 

cc: @TonghuiMing 

Kara_Shindle
Occasional Contributor III

I've had some issues with the web experience I've built not consistently displaying the correct view when a button is clicked.  I have 4 views that work like 60% of the time but then sometimes it will display the wrong one, and only refreshing the cache seems to (sometimes) fix the issue.

0 Kudos
TonghuiMing
Esri Regular Contributor

@MelanieWilliams1 @Kara_Shindle - Any app to share or reproducible environment? It seems like your projects/apps are quite large and more information could be helpful to identify the problem.

0 Kudos
MelanieWilliams1
New Contributor III

Sure, this is one of the few that we have public facing at the moment and about as large/complex as we have published publicly.  We have other larger, more complex one internally but don't use them much because the do crash more.  However, the part that has thrown our troubleshooting off the most is that one project may be really small and simple, yet crash constantly one day, then not at all or just very little another day.  Or a medium size project that doesn't crash at all.  I had a theory that it was embedding a dashboard but that didn't totally hold up.  We can not seem to link it to the project size, data size, browser, or a specific widget.  Currently, we are testing out to see if it has to do with spikes in memory use. 

Thanks for the question and interest in helping.

0 Kudos
TonghuiMing
Esri Regular Contributor

It appears that the link above is directed back to this post.

0 Kudos
Mmwilliams
New Contributor III

Sorry about that.  Here is that example (https://experience.arcgis.com/experience/0be3d6e45b3c4c5da10305dc8cc195c7/).  I have not seen any issues with this one in the past month but I haven't touched it since maybe February.  There is another internal one that is crashing a lot for folks.  I can't share it but there are two pages.  First page consists of three embedded dashboards.  Each dashboard is connected to the same dataset but shows different ways to summarize the data (map, bar and pie charts, indicator widgets and detail lists).  The dataset has only about 20 attributes in it and we are only up to 50 test records.  The second page uses the same dataset. It has one survey, a map that feeds a second survey, and feature detail widget.  

This crashes in all browsers but the most in Firefox.  We definitely see more crashes with projects that have dashboards embedded but still occurs with project where there are only basic experience builder widgets and no special effects configurations.  

Has anyone else been able to narrow down any ideas of a cause?  

0 Kudos
MelanieWilliams1
New Contributor III

We have another one that constantly crashes EVERY time in Firefox but not in Chrome.  Here is the public version of that map.  There are a lot of layers but they are all off by default when you load the map.

https://experience.arcgis.com/experience/689283d17bf342c2a96364fbab09a5d8/

0 Kudos