ExB 1.9 Dev is broken? Strange errors out of no where when downloading an app package

3840
24
09-06-2022 01:22 PM
ScottHiggins_PVGIS
New Contributor III

Not sure if anyone else is experiencing issues out of nowhere with their 1.9 Dev Experience Builder environments. But two of us are having the same issue in separate environments.

 

Friday afternoon, I was able to export/download Application packages to put into our hosting environment. I have updated nothing and didnt touch it since the last successful download Friday afternoon 3pm.

 

Exporting a new edited today, I invariable get "Not found" error or 

ScottHiggins_PVGIS_0-1662495207311.png

And my Server command throws weird errors:

ScottHiggins_PVGIS_1-1662495270879.png

I dont even know why. One our our technicians, separate environment (local 1.9 dev) gets the same error when exporting, or a variation:

ScottHiggins_PVGIS_2-1662495541442.png

 

So obviously something major is going on with the dev environment. This is putting us seriously behind on our development cycle when we cant even export versions into our test host environment. He exported a version this morning no problem.

 

Could someone please help, explain what the heck has changed with the stuff, or better yet fix your stuff. This getting to be unreliable as an application development environment. Sigh, ESRI.

24 Replies
ScottHiggins_PVGIS
New Contributor III

Well, still broken today for two of us. It seems to be populating icons and something to do with calcite components, which isnt even referenced or used in apps:

 

ScottHiggins_PVGIS_0-1662553024339.png

 

ScottHiggins_PVGIS_1-1662553573645.png

 

 

RobertScheitlin__GISP
MVP Emeritus

@ScottHiggins_PVGIS  I am getting the same issue today (9/8/22). Strange as I have downloaded a few apps from 1.9 last month. Have you opened a ticket with Tech Support?

chapmunnhsc
New Contributor III

@RobertScheitlin__GISP -

 

Did you find a fix for this? I've run into the same issue. Thanks.

RobertScheitlin__GISP
MVP Emeritus

Nope. I never got past this.

chapmunnhsc
New Contributor III

Dang. I've done clean installs of Node and ExP, and keep running into the same issue. Have an open case with Esri and trying to work through the issue. Will report back if I learn anything.

kim_hspartner
New Contributor II

@ScottHiggins_PVGIS  We have Esri support ticket open but not much progress.  I am trying to narrow down the possible cause:

  • Which OS do you use?  I am on Windows 10 and not experiencing the issue, while another developer in our organization is on Windows 11 and experiencing this issue.
  • Do you happen to use `@arcgis/core` module in your custom development?
  • Do you happen to have a folder named "tests" anywhere in the custom widget(s) you wrote? 

 

Jianxia
Esri Regular Contributor

@kim_hspartner - could you please let us know Esri support ticket number you opened?

0 Kudos
LuisAntonioRodriguezGonzalez
New Contributor III
@kim_hspartner - could you please let us know Esri support ticket number you opened?
This is the Esri Case #03182119 - [Experience Builder Dev]: Error export/download Application in 1.8 and 1.9 versión

Regards
chapmunnhsc
New Contributor III

This started happening to me last week too! I've tried reinstalling Node, ExP Developer, and rolling back to a previous build  with no success. 

0 Kudos