Error viewing changes to Experience Builder apps with ArcGIS Assistant (AGOL)

1319
6
05-23-2022 04:39 PM
Labels (1)
HaydenRickard
New Contributor

Apologies if this has already been posted/solved already!

My organisation has recently started creating apps using experience builder in AGOL, rather than WAB.

In the past, we would have dev, test, and prod versions of WAB apps and apply changes to each by copying json across using AGO/ArcGIS Assistant (and repointing web map/feature service URLs etc). This worked well and we could see the changes when editing the prod version of the WAB app.

This does not seem to work for experience builder apps though, as changes made by copying json do not show up in the edit interface, but do when accessing the app directly.

I've added three screenshots that show this below (all after json has been copied).

  • Viewing the app via URL after the json has been copied (text change and map added)
  • The app in the edit interface after the json has been copied (text unchanged and image rather than map)
  • Confirmation that the json has been changed

Any help with this is much appreciated! Being able to make quick changes/bug fixes for the prod version via the normal edit view is very useful and would be great if it can be fixed.

6 Replies
jcarlson
MVP Esteemed Contributor

I don't use EB on AGOL, and almost exclusively use the Developer Edition, but when I look at the files that a single Experience is using, there's more than just one JSON file.

From your screenshot, it looks like the AGO Assistant is seeing the config.json file. EB has the newer feature of separating saving from "publishing", so there's a built-in separation between your latest edit and what the users see when the app is accessed.

In the Developer Edition, the editor interface accesses a separate tmp folder. I would guess that the AGOL version is doing something similar. You're only able to copy the JSON to the published version of the app, but the files in that tmp folder that the editor uses are still stuck at the older version.

Are you clicking "publish" before copying the JSON? To be clear, you probably need to click "publish" on both apps (source and destination) before copying the JSON. Publishing the app tells it that it no longer needs the tmp files, because there are no unpublished changes to track.

- Josh Carlson
Kendall County GIS
HaydenRickard
New Contributor

Thanks for the explanation, it helped a lot and made the way experience builder functions behind the scenes make more sense.

Both apps had all changes saved & published before copying the json across, so that doesn't seem to be the issue unfortunately.

0 Kudos
ShelleySchulte1
New Contributor III

Hello! Did you ever find a solution for this? My organization does the same thing, we have dev and prod environments. 

MattChomicky1
New Contributor III

Same issue here. I made a whole experience that took me several days of work to configure, and then I decided I wanted to group the map layers. This broke all of my widgets because the layer IDs changed. Normally, if this were Web AppBuilder, I would just update the JSON to point at the new layer IDs, and this is what I tried with the ExB app - changes partially worked in the published item, but when I open it in Edit mode everything is still broken.

0 Kudos
Kuyler_JonesCivil
New Contributor II

I am looking for a solution to this as well. This thread seems to best describe my objective and the issues involved.

The item's Resources tab in the new ArcGIS Assistant contains a handful of files associated with the Web Experience. This is where I would expect a tmp file to be available, if that function is ever implemented for AGOL. For now, it looks like only the config file is accessible.

0 Kudos
MGEGIS
by
New Contributor II

Use this AGOL Assistant:

AGOL Assistant: https://assistant.esri-ps.com/

I was able to edit the config file, same JSON as the published item.  Saved it and it worked!  The EB editor now matches what is published.

I found the answer from here:

https://www.youtube.com/watch?v=MLh1JmF9GVg

 

 

0 Kudos