Dynamic content not appearing/changing

1788
5
Jump to solution
04-05-2022 01:36 PM
Labels (2)
RenBou
by
New Contributor II

This seems like such a simple issue but it isn't working and I don't understand what I'm doing wrong.

I'm using Experience Builder with the Jewelry box template. I can add the attribute value to the sidebar (so it is connecting with the data), but the actual information from the sheet doesn't show up.

I've had a similar issue in the past when I did Get started with ArcGIS Experience Builder: Fill an app template with your own data training. I could only get it to show the first bird for every block on the sidebar. 

What am I doing wrong? How do I get it to dynamically list the data? 

RenBou_0-1649190595767.png

Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
RhettZufelt
MVP Frequent Contributor

If I add a List widget, then Select data and point to the dataset:

RhettZufelt_0-1649263130599.png

 

Then select one of the text box's in the list widget, and press the Dynamic content button and pick "Name" from the list of attributes (now that the widget is connected to the new datasourse):

RhettZufelt_1-1649263188616.png

 

Then click the other text box, Dynamic content button, "About" attribute field:

RhettZufelt_2-1649263224439.png

Then, when I select Live view, Preview, or publish/view the Experience, it is being populated with the attributes from the data.

R_

 

View solution in original post

0 Kudos
5 Replies
RhettZufelt
MVP Frequent Contributor

It looks like you are using the List widget.

Once you have selected data, you need to configure each "box" in the widget so it knows what field to pull the data from dynamically.

RhettZufelt_0-1649196278337.png

RhettZufelt_1-1649196313673.png

R_

0 Kudos
RenBou
by
New Contributor II

I've used the Dynamic Content button, but it doesn't seem to be connecting to my data. 

For example, when I use the Place Explorer template with AGOL, the feature works fine. It shows me the "auto-populate" option. 

Annotation 2022-04-06 113902.jpg

But when I use my own data (or the Birding in Boston data) it doesn't give me that auto-populate option within the Dynamic Content button. 

RenBou_0-1649259792718.png

 

0 Kudos
RhettZufelt
MVP Frequent Contributor

If I add a List widget, then Select data and point to the dataset:

RhettZufelt_0-1649263130599.png

 

Then select one of the text box's in the list widget, and press the Dynamic content button and pick "Name" from the list of attributes (now that the widget is connected to the new datasourse):

RhettZufelt_1-1649263188616.png

 

Then click the other text box, Dynamic content button, "About" attribute field:

RhettZufelt_2-1649263224439.png

Then, when I select Live view, Preview, or publish/view the Experience, it is being populated with the attributes from the data.

R_

 

0 Kudos
RenBou
by
New Contributor II

It works! For whatever reason the List widgets in the templates weren't giving me the auto-populate option but when I plugged in a new List widget, it works like a charm. Yay! THANK YOU SO MUCH!

0 Kudos
RamakrishnaDesetti
New Contributor

How can we write expression with if condition

0 Kudos