[Bug or normal behaviour in version 4.18?] Webmap with time enabled layers overwritting custom widget configuration

486
2
Jump to solution
01-21-2021 01:22 PM
WilsonFranca
New Contributor

Hi,

I am working on a custom time slider widget that interacts with a Map widget in Experience Builder Dev Edition using the JimuMapViewSelector and JimuMapViewComponent. The data source of my map widget is a web map with time enabled feature layers.

With the API version 4.17, I can set up the time slider properties in the widget without a problem, changing mode, stops, play rate, start value for thumbs, and so on.

However, with the API version 4.18, all the time slider properties set within the widget are being ignored/overwritten by the web map time configuration.

For example, my time slider is on mode 'instant,' but it renders as mode 'time-window' (default). The same goes for all the other properties.

Insights:

  1. When I console.log(timeslider.mode) in a UseEffect after the time slider is rendered, it returns to me that the mode is 'instant' (as it was set on my code) instead of 'time-window' (as rendered);
  2. The widget only renders correctly if I don't set the property view in the time slider with the API version 4.18, but I lose the client-side rendering out of the box;
  3. I am using the workaround for API version 4.18 proposed in one of my coworker's thread (https://community.esri.com/t5/arcgis-experience-builder/major-bug-infinite-requests-after-closing-po...);

I am using:

  1. Experience builder version 1.2;
  2. OS Ubuntu 18.04 64-bit;

I was wondering if this is an intentional change in its behavior when using a web map with time-enabled layers as a data source in a map widget or if it is a bug?

I was also wondering if someone would have any insights on how to work around this?

Thank you.

1 Solution

Accepted Solutions
WilsonFranca
New Contributor

I was able to solve this issue by removing the view declaration from the Time Slider widget, setting the Map View Time Extent on Map View Creation, and updating the Map View Time Extent when the current time extent of the Time Slider changes.

View solution in original post

2 Replies
UalasRohrer
New Contributor III

I'm also interested in a possible workaround for this situation.

WilsonFranca
New Contributor

I was able to solve this issue by removing the view declaration from the Time Slider widget, setting the Map View Time Extent on Map View Creation, and updating the Map View Time Extent when the current time extent of the Time Slider changes.