Select to view content in your preferred language

Action "Record selection changes" with Trigger "Select data records" stopped working

1582
23
02-29-2024 03:22 AM
Labels (1)
kabukow
New Contributor

Hi, we had multiple Experience Apps set up with a map actions and trigger "Select data records" where one layer while selected caused selection of another layer by common ID. These actions stopped working today. We tested that on different apps, using different datasets both of which function properly and are not corrupted in any way except for the above. Is this a bug that ESRI is working on or can it be fixed differently?

Thank you

23 Replies
Jianxia
Esri Regular Contributor

@NBC , could you please provide a repro sample? We are not able to reproduce it.

0 Kudos
Jianxia
Esri Regular Contributor

@NBC , Select record trigger from List to Survey has been addressed.

0 Kudos
Jianxia
Esri Regular Contributor

@NBC , record selection trigger from the Search widget to the Map widget is now working for me. Could you please help confirm them?

0 Kudos
TianWen
Esri Contributor

We're unable to reproduce the issue. Would you be able to provide a sample app for further investigation?

0 Kudos
NBC
by
New Contributor III

@Jianxia no problems its an internal application and we cannot share unfortunately so will attempt to explain.

We have a search widget which is using as its data source a point layer in a map.  The point layer is hidden and represents a 1:1 relationship to another layer in the same map containing land parcel polygons.

When the user searches the address field from the address points layer in the search widget they should be zoomed to the location in the map to show the extent of the parcel, which has the same common identifier as the address point and  selects the parcel in the map to show the user. 

The zoom to trigger when record selection changes from search to map works, its just that the select data records does not work.  The common field used to join point to polygon are both text strings and previously this worked well.

I tried just removing the widget, re-adding and setting up the trigger again but its still not working.

Thanks for your help!

 

0 Kudos
NBC
by
New Contributor III

@Jianxia . The Search widget to Map widget select data records trigger looks to be working now - thank you.

The other issue, which is in a separate internal production app so again will attempt an explanation.

We have a list widget and a survey widget - both using the same point layer datasource.

The survey widget is in 'edit an existing record' mode.

The list widget is in 'single' select mode.

The Framework Select data records trigger from List to Survey is set to Auto bound. It was working well previously, populating the survey with the existing data,  now get the 'Editing is not possible because of the globalid parameter was not provided' message across the top of the survey widget.

Our workaround it to select the point in the map,  as the trigger from Map widget to Survey widget still works, however our users are getting confused by this change in workflow.

Thanks again for any help you can provide.

 

0 Kudos
Jianxia
Esri Regular Contributor

@NBC , I was able to reproduce the issue with the List and Survey widgets. We are looking into it. Thanks for the detail information.

0 Kudos
JustinCurtis2
New Contributor

Our organization is experiencing an issue where you have to click the search result a couple more times to achieve the record selection. 

1. Using search widget to search for an address

2. Using address output as a trigger to select the record in a polygon parcel layer (using Framework)

Before the last update, you just clicked on your search result and the parcel would be selected, and the pop-up would also appear, all with one click. Now you have to click twice more on the search result from the widget to get the same result.

0 Kudos
Jianxia
Esri Regular Contributor

@JustinCurtis2 could you please provide a reproducible sample or contact Esri Support? 

0 Kudos
stariq22
New Contributor II

https://experience.arcgis.com/experience/4d2e8ef6b21343ddb243894f58df94f3

When you conduct a search using any specific address, such as 950 S Magnolia ave., you need to double-click on the search result for the pop-up to appear and the parcel to be highlighted. This is under the functionality of our search widget, which has the 'Auto select the first result' option enabled. Prior to the February update, this feature would automatically highlight the parcel and present the pop-up without requiring a second click. Our address search is using a custom locator and below is the screenshot of the action: 

stariq22_0-1709774562612.png

 

 

0 Kudos