what server version is required to create an enterprise database

1340
1
Jump to solution
06-15-2016 04:43 AM
DavidBrokamp
New Contributor

I am trying to create a new SQL server database as a geodatabase.  When using the create enterprise database tool, i get an error that the keycodes file is not valid.  I am using the standard license for ArcCatalog, and we have a workgroup license for ArcGIS Server.  I have tried registering the server license again, but it still gives the same error.

Do we have to have a higher version of ArcGIS Server than Standard Workgroup to create a geodatabase in SQL Server that can be edited using the editor in ArcMap?

We are able to create feature classes in an existing SQL server database, but are unable to edit those feature classes within ArcMap because (I think) the database is not registered as a geodatabase.

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

Hi David,

You can only create a Workgroup geodatabase with a Workgroup license. The Workgroup license uses SQL Server Express for the geodatabase storage. You do not use the Create Enterprise Geodatabase GP tool for this product.

Here is the help documentation of Database Server (Workgroup level): Database servers—Help | ArcGIS for Desktop

In order to use the Create Enterprise Geodatabase tool, you need to have any level of ArcGIS for Server Enterprise licensing (Basic, Standard or Advanced). See pages 4 - 8 of this link: http://www.esri.com/~/media/Files/Pdfs/library/brochures/pdfs/arcgis-server-functionality-matrix

Features | ArcGIS for Server

Geodatabase

--- George T.

View solution in original post

1 Reply
George_Thompson
Esri Frequent Contributor

Hi David,

You can only create a Workgroup geodatabase with a Workgroup license. The Workgroup license uses SQL Server Express for the geodatabase storage. You do not use the Create Enterprise Geodatabase GP tool for this product.

Here is the help documentation of Database Server (Workgroup level): Database servers—Help | ArcGIS for Desktop

In order to use the Create Enterprise Geodatabase tool, you need to have any level of ArcGIS for Server Enterprise licensing (Basic, Standard or Advanced). See pages 4 - 8 of this link: http://www.esri.com/~/media/Files/Pdfs/library/brochures/pdfs/arcgis-server-functionality-matrix

Features | ArcGIS for Server

Geodatabase

--- George T.