Unable to connect to ArcSDE 9.3 from Geoprocessing service published using ArcGIS Server 10.4

1560
0
06-15-2016 10:36 AM
VinuthaDevakumar1
New Contributor


I am working on an application that accesses a table on  ArcSDE 9.3. Recently we upgraded to ArcGIS Server 10.4. Although ESRI says ArcSDE 9.3 is not compatible with 10.4, I ran the geoprocessing model in Desktop 10.4 making a connection to ArcSDE 9.3. Since this worked I published the geoprocessing service. However when I call the service, the ArcSDE connection is not established and so the table residing there is not accessed at all. I have tried various ways of connectiong to the sde using absolute and relative paths. I also tried to use the sys.path[0] in the python script of the geoprocessing model. Everything works within the desktop environment. When I publish it as a geoprocessing service, it fails to connect to sde. I am wondering if its the compatibility issue with ArcSDE 9.3

Any suggestions is greatly appreciated. Thank you in advance.

0 Kudos
0 Replies