Select to view content in your preferred language

WebAdaptor 10.9.1 on tomcat "Unable to connect to Webadaptor URL" from Linux command line

652
2
10-20-2022 08:07 AM
RobertRaines
New Contributor II

I am following the instructions at https://enterprise.arcgis.com/en/portal/10.9.1/administer/linux/use-a-non-default-port-for-the-porta...

But I receive the error "Unable to connect to Webadaptor URL".

The tomcat logs set to FINE report "X.X.X.X - - [20/Oct/2022:8:00:00 -500] "-" 400 -"

The tomcat user and group has full write access to the .webadaptor directory, SELinux is configured properly (also tried with it turned off), and the firewall is configured correctly (also tried with it turned off)

Has anyone seen something similar? 

Tags (3)
0 Kudos
2 Replies
StevenBowden
New Contributor III

Not sure if you have seen this page. It may be related and may be of some help.

https://community.esri.com/t5/arcgis-enterprise-questions/problem-to-configure-webadaptor-10-8-1-w-t...

I just ended up going with a IIS web adaptor as it suited uor deployment better anyway.

0 Kudos
RobertRaines
New Contributor II

I am familiar with the issue, the .webadaptor directory is accessible to the tomcat user.

I made a SSH tunnel and registered the WebAdaptor through that since the server is headless, that worked for our ArcGIS Servers but now Portal just shows a blank page after login. I haven't had issues like this since 10.3.

 

0 Kudos