Web Adaptor for ArcGIS Server is not taking domain name - ArcGIS server Enterprise 10.6

3760
7
Jump to solution
02-27-2018 02:26 AM
ThomasPuthusserry
New Contributor III

Using ArcGIS Enterprise Builder 10.6, a basic single site installation was setup. By default the Web Adaptors for both portal and server were linked to the internal server path. When accessing the portal and the published contents within the network, it works fine. The server is also mapped to a domain name with ssl bindings to access the ArcGIS portal and ArcGIS server from outside network. 

By default the portal's Web Adaptor setting has not picked up the external URL. By following this URL this has been changed manually to link to the domain name of my server. However, the ArcGIS server Web Adaptor URL is still showing the internal server name, and there is no way this can be changed. 

The issues:

1.    I can't access the published contents through the ArcGIS Portal from outside the network (through the domain url).

2.   I can't access the federated server manager from outside the network (through domain url)

System details:

Windows Server 2012 R2

IIS 8 with ssl enabled and mapped to domain

ArcGIS Enterprise 10.6

Portal internal url: https://gis-serverXX.xxxxx.local/portal (working fine)

Server internal url: https://gis-serverXX.xxxxx.local/server(working fine)

Portal external url: https://dev2.mydomain.com/portal (working fine)

Server external url:https://dev2.mydomain.com/server (not working)

Any suggestions on how to get this fixed will be very helpful, as I have been struggling with this installation for the last one week and replicated the issue in two different servers.

Thanks Thomas

0 Kudos
1 Solution

Accepted Solutions
ThomasPuthusserry
New Contributor III

Actually I figured this out: The issue comes when federating the server. In my case, I gave both service URL and Administration URL as the ssl domain name. The correct one which works is :

Services URL: https://dev2.mydomain.com/server

Administration URL: https://servername.domain.local:6443/arcgis

Hope this will be helpful to anyone comes across same issue.

Thomas

View solution in original post

7 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Looks like you are already looking at https://community.esri.com/message/753476-re-arcgis-server-federated-with-portal-installed-with-buil...    adding link for others.  I do not have a solution myself, just referencing.  

0 Kudos
JonathanQuinn
Esri Frequent Contributor

I think you have two options:

1) Use the hosts file under C:\Windows\System32\drivers\etc to set the alias so the Builder will use that hostname for configuring everything:

Ex.

10.0.0.1 webgis.domain.com

This will also cause the machine names of all components to be set to the alias as well, which shouldn't be a problem considering everything is on the same machine.

2) Configure everything manually using the correct URLs. This means installing the components, creating sites, registering web adaptors, and federating manually.

There's also the option of letting the Builder set everything up, but then you unfederate, update the URLs to point to the alias, and then re-federating. I'm not sure if that really follows the story of the Builder, though...

ThomasPuthusserry
New Contributor III

Hi Jon

Thanks for the tips, and I have followed option 2: to install everything manually, then federate. I have also installed the DataStore and configured the hosting server as well.

Everything works fine, except that I can't run any of the 'Analysis' as I get the error: Create Service exception ' Exception: hostname in certificate didn't match: != OR '

I am using a wild card SSL (*.mydomain.com) to access server / portal through an alias name (https://dev2.mydomain.com/server and https:dev2.mydomain.com/portal).

Any idea where I am making the mis-configuration? 

Thanks very much Thomas

0 Kudos
ThomasPuthusserry
New Contributor III

Actually I figured this out: The issue comes when federating the server. In my case, I gave both service URL and Administration URL as the ssl domain name. The correct one which works is :

Services URL: https://dev2.mydomain.com/server

Administration URL: https://servername.domain.local:6443/arcgis

Hope this will be helpful to anyone comes across same issue.

Thomas

View solution in original post

JohnBrockwell
Occasional Contributor II

Is dev2 your web adaptor machine?

0 Kudos
ThomasPuthusserry
New Contributor III

Actually my GIS server and web adapter are in same machine. I use a wild card SSL certificate so dev2 an A record to map the IP of the server.

0 Kudos
AnninaHirschi_Wyss1
Occasional Contributor III

Hi Thomas Puthusserry

I have just a question, I think we have a similar issue here. Did you use the "*.mydomain.com" also inside ArcGIS Server and Portal configuration or only on IIS level?

If you use the "*.mydomain.com" Cert on the ArcGIS server/portal, do you get a certificate error on e.g. https://servername.domain.local:6443/arcgis/rest or https://servername.domain.local:7443/arcgis/portal

if so, do you just live with this, as it is only for internal purpose?

Thanks,

Annina

0 Kudos