Web Adapter Silent Install Issue - Looks like it Installs - But isn't there

07-06-2017 02:50 PM
Occasional Contributor III

We have an ArcGIS Server 10.4.1 site that runs in IIS 7 through the Web Adapter on port 80 (HTTP only). I installed 3 Web Adapters several years ago for different access points to this server. All these installs were done silently as required by the name and site number conflict using the wizard.

Now we have decided to upgrade to 10.5 and we want our new server to use HTTPS. We also want to install Portal. So we are creating brand new sites and installs for these on new virtual servers.

I created the two new sites in IIS (one for the new ArcGIS Server and one for Portal)

I was having trouble installing the new 10.5 Web Adapter silently from the command line.

So I closed CMD and re-opened it using the Run as Administrator option.

The Web Adapter installed fine on the first try on the site I dedicated to ArcGIS Server, but I cannot for the life of me get it to install on the second site I was dedicating to Portal.

The weird thing is, it goes through the entire install process and everything looks like it worked just fine (no errors), but when it finishes, it just isn't there.

I am positive I am assigning a unique name, and the site number is correct.

All the permissions are set the same for both sites and the bindings are set on both for port 443.

Does any one have any incite on this?

Has anyone else tried to do a silent install and it looks like it works, but never actually gets installed?

Here was my exact process below... (and yes i even tried to use port 80 and that didn't work either.

Run cmd as administrator

cd C:\Temp\ArcGIS_10.5\WebAdaptorIIS\SetupFiles

msiexec /I setup.msi /qb VDIRNAME=arcgisserver WEBSITE_ID=9 PORT=443 ADDLOCAL=ALL (installed first try)

msiexec /I setup.msi /qb VDIRNAME=arcgisportal WEBSITE_ID=10 PORT=443 ADDLOCAL=ALL (will NOT install)

0 Kudos
0 Replies