view attachments (or hyperlinks) in web appbuilder for portal in a related table

560
3
01-29-2020 01:14 PM
LorindaGilbert
Occasional Contributor II

Hi,

I'm attempting to see attached pdfs that are in a table that should be related to a feature class.  I'm doing this in web app builder for portal at V10.7.1.  I don't seem to be able to get the attachment portion of the configuration to do this.

Thanks,

Lorinda

0 Kudos
3 Replies
jill_es
Esri Contributor

Are you able to view the attachments in the map viewer or at the REST endpoint?  (Essentially, removing the Web AppBuilder from the equation).

0 Kudos
LorindaGilbert
Occasional Contributor II

Edited to say that no I can't.  I've redone this table so many times that I've lost track of where I was.  However, that is at this time.  I do believe that I had it at one time with the fully qualified UNC path to the pdf by prefixing the file name with the UNC path.  Will have to rerun the data, repub and then check.

So I guess I might have used the wrong term, it could be hyperlinks rather than attachments.  It's just that in the source data that they are coming from they are called attachments, but are really hyperlinks there as well.

I have edited the title and tags to reflect that it could be hyperlinks instead.

Thanks.

0 Kudos
jill_es
Esri Contributor

Hi Lorinda - thanks for clarifying.  Just to make sure we're both on the same page here, your data looks like this...

...and not this?

Assuming the first screenshot is what you're seeing, did you publish it from ArcMap or ArcGIS Pro?  Or did you create it directly within ArcGIS Enterprise?

0 Kudos