Upgrading with ArcGIS Enterprise Builder

557
6
01-18-2018 05:43 AM
JordanMiller4
Occasional Contributor III

If we use the ArcGIS Enterprise Builder to upgrade our enterprise from 10.5.1 to 10.6 will we have to change any information? We'd like to leave the credential name and password we used to upgrade from 10.3.1 to 10.5.1 mid-last year.

Thanks,

Jordan

0 Kudos
6 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Jordan,

I don't believe you can use the ArcGIS Enterprise to upgrade a previous installation.  I tried this yesterday, but received an error that the previous installation must be uninstalled.

ChelseaRozek
MVP Regular Contributor

Jonathan Quinn‌ mentioned in another thread that: "...ArcGIS Enterprise Builder can only be used to upgrade an existing site that is also deployed using the ArcGIS Enterprise Builder, meaning upgrades will be supported starting at 10.6, given the Builder is available at 10.5.1."  

We have a dev 10.5.1 created with the Builder that we'll try upgrading to 10.6 in the next couple of days. Hopefully it goes smoothly.

ChelseaRozek
MVP Regular Contributor

Update: I just ran the 10.6 builder on our dev 10.5.1 Enterprise server (installed via Builder originally) and it upgraded the components and left my users and groups in Portal intact (don't have items in there yet). We didn't have to change any account names or anything during the upgrade. We did have to reenter our authorization numbers because they're now the ones for 10.6. The builder did miss upgrading our server web adaptor (but got our portal one), so I had to manually uninstall and install a 10.6 one with the same name. After the install, you run the Enterprise Configuration Wizard, and at the end it tells you to reindex your Portal, so I did a full index.

JonathanQuinn
Esri Frequent Contributor

Thanks for the update on this, the Builder should update the whole stack, so I'm not sure why it missed the server Web Adaptor. Did it not uninstall it, or did it uninstall but not install?

0 Kudos
ChelseaRozek
MVP Regular Contributor

Here's what it looked like after I ran it. The server Web Adaptor was left at 10.5.1, which I only noticed after the Configuration Wizard complained that not all components were at the same version and couldn't proceed.

screenshot of esri programs from the add/remove programs window

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Did you save a config.xml file?  I have not used the builder so I'm not sure if it has this same option or not, but might be worth looking into.

0 Kudos