UpgradeGDB : Could not update server tables and stored procedures (Error = -549)

143
2
Jump to solution
07-27-2022 05:08 AM
sl_dsny
New Contributor II

Hi all,

Attempting to upgrade our SDE from 10.6.0 to 10.8.x. I had tested the upgrade in a staging environment a couple of weeks ago by restoring the original SDE and upgrading to 10.8.x with no issues. 

Trying the upgrade in both our staging (with latest backup) and original environment results in the error below. The only hint I've found is this article but as far as I can tell we aren't utilizing historical or archive functionalities: https://support.esri.com/en/technical-article/000011277

Somethings definitely changed in the past couple of weeks that I probably wasn't made aware of and hoping to narrow down that issue.

Executing: UpgradeGDB G:\!_Geospatial_Connections\xxxx.sde PREREQUISITE_CHECK UPGRADE
Start Time: Wed Jul 27 07:53:47 2022
Paused the database for upgrade.
There are no other active connections.
User has privileges required to upgrade.
Running Pre-Requisite check (G:\!_Geospatial_Connections\xxxx.sde).
Instance supports XML type.
Updating server tables and stored procedures.
Successfully enabled database option ALLOW_SNAPSHOT_ISOLATION and READ_COMMITTED_SNAPSHOT.
Could not update server tables and stored procedures.
Refer to upgrade logfiles for more details:
C:\Users\xxxx\AppData\Local\Esri\Desktop10.8\GDBUpgrade.log
C:\Users\xxxx\AppData\Local\Temp\sde_setup.log
Unpaused the database.
Failed to execute (UpgradeGDB).
Failed at Wed Jul 27 07:53:47 2022 (Elapsed Time: 0.52 seconds)

Edit: Fixed original claim about it working on staging environment.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
sl_dsny
New Contributor II

I figured out the solution. 

Someone had added the SDE user to the sysadmin role. By removing SDE from that role I was able to perform the upgrade successfully.

Unfortunately, I had glossed over the warning from this document since we never had SDE under the sysadmin role prior: https://desktop.arcgis.com/en/arcmap/latest/manage-data/gdbs-in-sql-server/upgrade-geodatabase-sqlse...

"Note: Do not add the sde user to the sysadmin role."

View solution in original post

2 Replies
MichaelVolz
Esteemed Contributor

Can you try upgrading the problematic SDE database to 10.7.x to see if you generate the same errors?

0 Kudos
sl_dsny
New Contributor II

I figured out the solution. 

Someone had added the SDE user to the sysadmin role. By removing SDE from that role I was able to perform the upgrade successfully.

Unfortunately, I had glossed over the warning from this document since we never had SDE under the sysadmin role prior: https://desktop.arcgis.com/en/arcmap/latest/manage-data/gdbs-in-sql-server/upgrade-geodatabase-sqlse...

"Note: Do not add the sde user to the sysadmin role."