Upgraded to 10.5, can no longer publish services...

20013
18
02-22-2017 12:25 PM
MarkLittell
New Contributor III

Upgraded from 10.4.1 to 10.5

I applied the 10.5 publishing patch

Copied the the st_geometry.so and libst_raster_pg.so from Desktop to the Linux server running the PostgreSQL 9.3

When I try to publish a new or update an existing service ArcMap returns the following error message:

   Packaging succeeded, but publishing failed.

   ERROR 001487: Failed to update the published service with the server-side data location. Please see the server's log for more details.

   Please consult the GP Results Window for enhanced error description or contact your administrator for the server logs.

The Server Logs read:

Error executing tool. PublishServiceDefinition Job ID: j868d0fe80d114806ab528cf36ac3fe7f : ERROR 001487: Failed to update the published service with the server-side data location. Please see the server's log for more details. ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition).

System/PublishingTools.GPServer

Failed to create the service.: Updating the server connection string for layer Shelters - County failed. Attempted connection string was ENCRYPTED_PASSWORD=<snip>;SERVER=1XX.XXX.XXX.175;INSTANCE="DSID=<snip>";DBCLIENT=postgresql;DB_CONNECTION_PROPERTIES=1XX.XXX.XXX.175;DATABASE=sde;USER=sde;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS. Table name is sde.sde.MyFeatureClass. Please verify the data exists on the server.

System/PublishingTools.GPServer

Failed to rename cache folder.

MyFolder/MyService _201702221422.MapServer

DoAfterSDExtraction failed.

System/PublishingTools.GPServer

SwizzleService failed.

System/PublishingTools.GPServer

Failed to rename cache folder.

MyFolder/MyService.MapServer

Method failed.HRESULT = 0x80070057 : The parameter is incorrect. .

MyFolder/MyService.MapServer

Method failed.HRESULT = 0x80070057 : The parameter is incorrect. .

MyFolder/MyService.MapServer

Service instance activation failed in 'MyFolder/MyService.MapServer'. AutomationException: 0x80004005 - Underlying DBMS error [FATAL: terminating connection due to administrator command could not receive data from server: Software caused connection abort (0x00002745/10053)::SQLSTATE=57P01] [sde.DEFAULT] in 'esriDataSourcesGDB.SdeWorkspace.1'

MyFolder/MyService.MapServer

Instance of service 'MyFolder/MyService.MapServer' failed to process a request.

MyFolder/MyService.MapServer

Tags (1)
18 Replies
DavidWesterlind
New Contributor II

This have been an issue with arcgis server since 10.1 at least. Something is fundamental wrong with the publishing process. I never had this kind of trouble with publishing in ArcGIS Server 10.0. 

ArcGIS Server 10.0 was lightyears better to handle mapservices with larger number of layers. In my organisation we are in to radically limit number of layers of each mapservice. Otherwise the site goes really slow. We are also removing the removing the policy to use more than 1 server per cluster. It doesn work anyway.

There is a patch for publishing 10.5 with arcgis pro, but not from ArcGIS Desktop. I think we need a patch again.....

Streltzer_Tracie
New Contributor III

We had a lot of issues with the 10.4.1 upgrade.  I have noticed that older SDE connections, even though they were direct connects, don't always open in 10.4.1 desktop.  We ended up having to replace many of our SDE connections before publishing would work, long with the updated 10.4.1 publishing patch.  Its still a problem every now and then, no apparent rhyme or reason, oracle or sql server, it just randomly happens.  Only solution is to apply the patch, create a new SDE connection file and publish, then remove the old connection files.  We re publishing with desktop 10.3.1 and 10.4.1.

0 Kudos
AvinashPatel1
Occasional Contributor III

Hello,

We have also upgraded to our ArcGIS server platforms from 10.4.1 to 10.5 and using oracle11g.

But no publishing error reported in our environment.

We are first created SD files then uploaded all SD files to AGS using ArcGIS server tools.

Our ArcGIS server deployed on Windows as well linux platform. 

MalcolmJacobson
Occasional Contributor II

I had the same problems as the original post after upgrading a 10.3 server to 10.5

Eventually resolved the problem by deleting all the records under Site > Data Stores and then re-adding them using database connection files created using ArcCatalog 10.5

0 Kudos
DionLiddell
New Contributor III

I had the same problem upgrading from 10.3.1 to 10.5.1.   I used your hint (thank you!), but instead of deleting the Data Stores, I imported the updated 10.5.1 SDE file for the database registrations that were giving me trouble.

0 Kudos
CattyannCampbell
Occasional Contributor II

Finally fixed our issue after a clean install of ArcGIS Server on my desktop and copying the data store profiles to the server. Once in a while we still get the 001369 error publishing error while re-publishing one of the older MXDs again renaming the MXD fixes the problem. Sometimes I noticed this happens when the server is busy...

0 Kudos
Javier_Pintos
New Contributor III

Hello everyone,

I have some error after migrate Server 10.5.1 to 10.6. 

Mark Littell‌ do you fix it issue?

Do you have any recommendation?

Thank you!

Javier

0 Kudos
WilliamWang
Occasional Contributor

Thanks to Mark who initiated this and everyone's contribution.

I had similar issue in the last 24 hours after trying to overwrite an existing Map and Feature Service (MFS).

This was most likely caused by recent upgrade of our SQL db and ArcGIS server to 2012 and 10.4.1, respectively. In hindsight, I should have upgraded to 10.5.1 but this isn't the point here.

These are the steps I took after reading through this thread. Not sure what was the one that fixed the publishing issue. I am inclined to say it is the newly established Database Connection string after upgraded to 10.4.1.

  • In ArcCatalog (AC), deleted my database connection and recreate a new one with the same credential. Open the mxd that I had issue publishing, and resource the data layer with the new connection by going through each layer in the TOC.
  • Log into ArcGIS Server Manager (ASM) >> site >> DataStore >> validate all Data store (Note: tried this before but did not help. Doing this again, simply as a precaution)
  • In AC, restart the Publishing Tool GP under System. (Note: tried restarting just this service before but did not work. Doing this again, simply as a precaution)
  • From the Mxd, shared and overwrote the MFS on the server....worked...phew~~
0 Kudos
baohuachu3
New Contributor III

My version is 10.5. After create a new geodatabase this issue appeared.

Tried some methods ,  create service by site admin works. See the link.  

The method is :

 

Overall steps:

  1. Create an msd
  2. Use ArcGIS Server Admin site to create a map service using the msd

 

Details:

To create an msd:

  • you can use arcpy.mapping.ConvertToMSD() function, OR
  • in ArcMap, open 'Customize' window from 'Customize | Customize Mode... menu item'
  • switch to 'Commands' tab
  • select 'Map Service Publishing' from 'Categories' list box.
  • from 'Commands' list box on the right, drag and drop 'Save Map Service Definition...' on to an existing toolbar
  • Close
  • use the newly added 'Save Map Service Definition' tool to create a msd and save it some place where ArcGIS Server Account has access to.

 

Publish a map service from ArcGIS Server Admin site:

  • Browse to http://yourServerMachine:6080/arcgis/admin/services/createService
  • Read the API Reference help on 'createService' operation. There should be a json that you can use as a boilerplate.
  • Make necessary changes in the boilerplate json.
    Most important ones are: name of the service, path to the msd etc.
  • paste the json in the only textbox available on the 'createService' operation page
  • click on 'Create'
  • once that is done successfully, and if the service is not started yet, you can use Admin Site or Manager to start the newly created service.

The example json file is as below, if  the service to be created under xxx folder ,the create service url should be  :

http://yourserver:6080/arcgis/admin/services/xxx/createService

{

    "serviceName": "<mapservice_name>",

    "type": "MapServer",

    "description": "",

    "capabilities": "Map,Query,Data",

    "provider": "ArcObjects",

    "clusterName": "default",

    "minInstancesPerNode": 1,

    "maxInstancesPerNode": 1,

    "instancesPerContainer": 1,

    "maxWaitTime": 60,

    "maxStartupTime": 300,

    "maxIdleTime": 180,

    "maxUsageTime": 600,

    "loadBalancing": "ROUND_ROBIN",

    "isolationLevel": "HIGH",

    "configuredState": "STARTED",

    "recycleInterval": 24,

    "recycleStartTime": "00:00",

    "keepAliveInterval": -1,

    "private": false,

    "isDefault": false,

    "maxUploadFileSize": 0,

    "allowedUploadFileTypes": "",

    "properties": {

        "useLocalCacheDir": "true",

        "outputDir": "C:\\arcgisserver\\directories\\arcgisoutput",

        "cacheDir": "C:\\arcgisserver\\directories\\arcgiscache",

        "filePath": "C:\\temp\\mymap.msd",

        "maxRecordCount": "1000",

        "supportedImageReturnTypes": "MIME+URL",

        "clientCachingAllowed": "true",

        "isCached": "false",

        "virtualOutputDir": "/rest/directories/arcgisoutput",

        "maxExportTilesCount": "100000",

        "ignoreCache": "false",

        "exportTilesAllowed": "false",

        "cacheOnDemand": "false"

    },

    "extensions": [],

    "frameworkProperties": {},

    "datasets": []

}

0 Kudos