Unauthorized Access to ArcGIS Server Manager

2481
6
07-26-2019 12:03 PM
AprilChipman
Occasional Contributor III

I am installing ArcGIS Enterprise 10.6.1 on a completely new virtual server, and plan to migrate existing services and data from a 10.3 Server and SDE SQL database over the next few months. (I'm going with Option 2 from the "Migrating standalone ArcGIS Server to ArcGIS Enterprise" whitepaper.)

IT set me up with a Local Admin account and password to use while installing the software on the server. The installation seemed to have gone well (with the help of Esri Tech Support) but I am getting 'Unauthorized Access' errors when I try to log into the ArcGIS Server Manager site under any windows login other than the one used to install the server software.

Is that how it is supposed to work? I can get to my 10.3 server manager site on any computer, as long as I supply the proper username and password to get into Server Manager. Have a missed a setting or step when installed ArcGIS Server Manager 10.6?

0 Kudos
6 Replies
MichaelVolz
Esteemed Contributor

Did you connect the new server site to Windows Domain (Active Directory) or LDAP and then assign at least one other user as an Administrator under the Role type in the Roles tab?

0 Kudos
AprilChipman
Occasional Contributor III

Uhhh...

How do I know if I connected the new server site to Windows Domain (Active Directory) or LDAP?

I found Users and Roles in the Server Manager, but they both say they are managed by Portal for ArcGIS and that I need to log in to portal.

I logged into Portal and it shows one user (me), which is a Level 2 Administrator.

0 Kudos
MichaelVolz
Esteemed Contributor

Hopefully the same ESRI tech support analyst can show you how to access the other domain accounts that are managed by Portal.  I do not have Portal set up in my enterprise site at this time, so I can easily still manage this task in AGS Manager..

0 Kudos
HarroldSompotan
Esri Contributor

From the looks of things, it appears that this new 10.6.1 is already in a federated state. 

If you are still seeing the 'Unauthorized Access' errors, can you share with me if what URL are you accessing the Server manager with?

1. Is it with https://machinename.com:6443/arcgis/manager or https://localhost:6443/arcgis/manager or https://dns.com/Webadaptorname/manager?.

2. What is the Service URL and Admin URL is set to for your federation:

  • Services URL—The URL used by external users when accessing the ArcGIS Server site. If the site includes the Web Adaptor, the URL includes the Web Adaptor address, for example, http://webadaptorhost.domain.com/webadaptorname. If you've added ArcGIS Server to your organization's reverse proxy server, the URL is the reverse proxy server address (for example, http://reverseproxy.domain.com/myorg). If your organization requires HTTPS for all communication, use https instead of http. Note that the federation operation will perform a validation check to determine if the provided Services URL is accessible from the server site. If the resulting validation check fails, a warning will be generated in the Portal for ArcGIS logs. However, federation will not fail if the Services URL is not validated, as the URL may not be accessible from the server site, such as is the case when the server site is behind a firewall.
  • Administration URL—The URL used for accessing ArcGIS Server when performing administrative operations on the internal network, for example, http://gisserver.domain.com:6080/arcgis. If your organization requires HTTPS for all communication (such as when using Integrated Windows Authentication), use https://gisserver.domain.com:6443/arcgis.

https://enterprise.arcgis.com/en/portal/10.6/administer/windows/federate-an-arcgis-server-site-with-...

AprilChipman
Occasional Contributor III

I get to the Server Manager using https://(machinename).(domain):6443/arcgis/manager and it takes me to this page (when logged onto the server under the username that installed the server software):

When I go to the Administration URL you listed above, I get an image of half a stylized blue globe/sphere.

0 Kudos
HarroldSompotan
Esri Contributor

If you are accessing https://machinename:6443/arcgis/ you will get that splash screen. That is an expected behavior. 

If you type in the full address with arcgis/manager or webadaptorname/manager, then it should re-direct you to the portal login page that you see above. 

0 Kudos